0

This and other questions/answers around the web recommend turning off SecureBoot to get systemctl hibernate to work when encountering the error:

Failed to hibernate system via logind: Sleep verb not supported

How can I get systemctl hibernate to work as designed (i.e. hibernate/suspend-to-disk) without disabling SecureBoot?

NB: I'd like to avoid pm-utils unless absolutely necessary. SystemD appears to be the way to do it and there are lots of suggestions that pm-utils doesn't work well together with SystemD.

  • I think there is no way to use hibernation with SecureBoot enabled, unless you recompile a kernel. Why do you need SecureBoot? It is completely useless. – Pilot6 Sep 17 at 21:03
  • 3
    Possible duplicate of 18.04 hibernate with UEFI and secure boot enabled – Pilot6 Sep 17 at 21:03
  • @Pilot6 I wonder why the site search and the link suggestions didn't bring this up while I wrote my question. I also voted to close as dupe. Thanks for bringing my attention to the already answered question. – 0xC0000022L Sep 17 at 21:07
  • You can close it as dupe instead of voting because it's your question. – Pilot6 Sep 17 at 21:08
  • @Pilot6 surprisingly I could not. When I clicked close the only thing it offered me was to vote just as you (?) did before me. Probably a matter of reputation/privileges. – 0xC0000022L Sep 18 at 11:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.