0

I'm using the ondrej/php PPA and have been for a while with no issues but I recently upgraded to PHP 7.3 and I've hit a snag.

I uninstalled all reference of the previous version and installed 7.3 and everything else is working fine but curl is not showing up in my phpinfo, but it is installed and according to the phpinfo it can see the curl.ini file

I even tried reinstalling the curl extension but no dice, still not showing up.

if I do apt list --installed | grep php this is what comes back:

dh-php/bionic,bionic,now 0.34+ubuntu18.04.1+deb.sury.org+1 all [installed,automatic]
libapache2-mod-php7.3/bionic,now 7.3.9-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
php-common/bionic,bionic,now 2:69+ubuntu18.04.1+deb.sury.org+2+php7.3 all [installed,automatic]
php-pear/bionic,bionic,now 1:1.10.8+submodules+notgz-1+ubuntu18.04.1+deb.sury.org+1 all [installed,automatic]
php-uuid/bionic,now 1.0.4-6+ubuntu18.04.1+deb.sury.org+10 amd64 [installed]
php-xml/bionic,bionic,now 2:7.3+69+ubuntu18.04.1+deb.sury.org+2+php7.3 all [installed]
php7.3/bionic,bionic,now 7.3.9-1+ubuntu18.04.1+deb.sury.org+1 all [installed]
php7.3-cli/bionic,now 7.3.9-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed,automatic]
php7.3-common/bionic,now 7.3.9-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed,automatic]
php7.3-curl/bionic,now 7.3.9-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
php7.3-dev/bionic,now 7.3.9-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
php7.3-gd/bionic,now 7.3.9-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
php7.3-intl/bionic,now 7.3.9-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
php7.3-json/bionic,now 7.3.9-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed,automatic]
php7.3-mbstring/bionic,now 7.3.9-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
php7.3-mysql/bionic,now 7.3.9-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
php7.3-opcache/bionic,now 7.3.9-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed,automatic]
php7.3-readline/bionic,now 7.3.9-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed,automatic]
php7.3-xml/bionic,now 7.3.9-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
pkg-php-tools/bionic,bionic,now 1.35ubuntu1 all [installed,automatic]

It's not showing up for either apache or cli.

I'm at a lost on what I can do to get curl working, I need it for one of my web apps.

  • Please provide the output of apt list --installed | grep php so we can see your PHP packages exactly. – fkraiem Sep 17 '19 at 5:18
  • If You have it installed You can enable it via command sudo phpenmod curl. Then verify by php -m. – Michal Przybylowicz Sep 17 '19 at 7:07
  • @MichalPrzybylowicz that didn't do it, still not showing up – Eman Sep 17 '19 at 13:09
  • @fkraiem I've updated my question with the results of that command – Eman Sep 17 '19 at 13:10
  • Nothing wrong there... Just in case, have you restarted Apache after installing/enabling the PHP curl module? – fkraiem Sep 17 '19 at 14:30
0

The issue was from a bad update with the PPA. Once I followed the instructions everything started working. If it wasn't for me noticing my server hasn't updated in a while I wouldn't have stumbled upon this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.