0

I just installed Lubuntu in dualboot with Win10 on a HP x2 tablet pc. I didn't have much trouble to install it, only had to disable the drive encryption on Win10 to resize the partition first.

But I'm having trouble with the battery. I keep getting notifications saying lxqt-powermanagement: no battery! I tried reinstalling that utility, I did a full update with Muon, I tried installing another battery monitor, and I checked that battery monitoring is enabled in both Lubuntu and the BIOS.

upower -d output below, while the unit is on battery:

greench@greench-pc:~$ upower -d
Device: /org/freedesktop/UPower/devices/line_power_ADP1
  native-path:          ADP1
  power supply:         yes
  updated:              dim. 15 sept. 2019 23:20:08 CEST (2569 seconds ago)
  has history:          no
  has statistics:       no
  line-power
    warning-level:       none
    online:              no
    icon-name:          'ac-adapter-symbolic'

Device: /org/freedesktop/UPower/devices/DisplayDevice
  power supply:         no
  updated:              dim. 15 sept. 2019 20:26:13 CEST (13004 seconds ago)
  has history:          no
  has statistics:       no
  unknown
    warning-level:       none
    icon-name:          'battery-missing-symbolic'

Daemon:
  daemon-version:  0.99.10
  on-battery:      no
  lid-is-closed:   no
  lid-is-present:  yes
  critical-action: PowerOff

Any help appreciated.

  • You haven't told us what release of Lubuntu, I maybe could assume it's 19.04, but it's safer to assume nothing and be told. The Lubuntu manual manual.lubuntu.me/3/3.2/3.2.12/power_management.html though I suspect your issues is ubuntu & hardware specific, but your release is the place to start. – guiverc Sep 15 at 23:05
  • I took the latest one, here are the details: Operating System: Ubuntu 19.04 Kernel: Linux 5.0.0-27-generic Architecture: x86-64 Following the manual link you gave me, I get a warning message, but doesn't seem relevant: greench@greench-pc:~$ lxqt-config-powermanagement (0x7ffedce82cb0) Warning: Icon theme "breeze" not found. – user128105 Sep 16 at 11:41
  • I tried to install laptop-mode-tools, and I tried both upower and acpi. Still the same error message, "No battery!". Any idea @guiverc ? – user128105 Sep 16 at 17:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.