3

I have a basic mouse connected to my computer running Ubuntu 18.04 via USB (it is a wired mouse). All of a sudden my mouse scrolling wheel stopped working. This is odd since it was working before, and I can confirm it is not a mouse hardware issue since the mouse wheel works fine on other computers.

I've tried unplugging and plugging the mouse back in, restarting my computer, getting all the latest updates with no luck. I tried toggling natural scrolling in the settings as others have suggested.

Also, I ran xev and the application did not pick up any activity when I used the middle scroll button. I am stumped and have no idea what else to try, it doesn't seem like many other people have had this problem there wasn't much troubleshooting available online.

2 Answers 2

0

The solution described in another post worked for my mouse A4Tech 2X Office 7K:

sudo apt install --install-recommends linux-generic-hwe-18.04 xserver-xorg-hwe-18.04
2
  • Hm, I tried this but still no luck. Maybe my mouse is just no longer supported or something. I'm all ears for any other suggestions though. Sep 19, 2019 at 3:37
  • Would this work for 20.04?
    – sanwablo
    May 15, 2020 at 12:56
0

If you have installed imwheel, try uninstalling it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.