1

Lubuntu 18.04.3 LTS on an Asus E402M laptop. Worked fine for years but after routine (using apt) patching beyond kernel 4.15.0-55-generic it now hangs on boot.

I suspected /boot/efi was being overfilled by a dual boot Windows installation so created a clean reinstall with sda1: a new 512M EFI partition with GRUB2 and sda2, a new Lubuntu 18.04.3. That should eliminate any Windows problems.

After a fresh install from ISO then apt-update && apt dist-upgrade I now have two kernels: 4.15.0-29-generic and 4.15.0-62-generic. 29 works perfectly. 62 hangs on boot.

62 in recovery mode gets started, installs the disk driver etc but hangs after installing the r8169 Gigabit ethernet driver. (The final message on screen is "Can't disable ASPM"). I cannot find any logs of this. (e.g. journalctl --list-boots has all the successful 0-29 boot logs, and no mention at all of failed 0-62 boots. I have configured journalctl to persist logs but no good).

Questions:

  1. Can anyone help me find log files to diagnose the problem further? (this feels like a basic thing I am missing!)

  2. Is it worth rolling back to the r8168 ethernet driver instead of r8169, or is that a red herring? I have downloaded a r8168 .deb but am reluctant to tinker before I have located the problem. r8169 seems to work fine in kernel 19.

  3. I believe all kernels up to (ubuntu label) 55 work fine, and none of the newer ones do. Does that fact help diagnosis?

Very grateful any help -- I'd be delighted to post some diagnostics if someone can answer Q1 and suggest where to look!

  • Have you tried any of the 5.x series kernels? – ajgringo619 Sep 15 at 16:50
  • Reading your post reminded me of usn.ubuntu.com/4115-2 (a regression in the 18.04 kernel fixed by -62), The no booting to could be reason for little info is in logs, but can you switch to text terminals? or boot into runlevel 1? Also I'd download & write the 18.04.3 ISO and try that (your re-install must be with an older install; as 18.04.2 & higher default to HWE enabled which would have you on kernel 5.0). Is there are reason you don't want HWE? or used an old 18.04 ISO for re-install? Booting the 18.04.3 live should have a later 5.0 kernel and give clues without re-install – guiverc Sep 15 at 23:27
  • Thanks, 5 series does the trick. You're right I (lazily) used an old recovery ISO followed by apt-update, not a fresh download. And frankly it didn't occur to me to go HWE since this is old hardware. I'd been hoping it would fix itself in the later GA releases (including today) but no. I won't investigate further since it now works but thank you for this good advice which might come in handy in future.... – Dave Skeet Sep 18 at 19:09
0

I had the same problem on an ASUS R417M, going from kernel 4.15.0-54 to 4.15.0-62 at recent APT update. I believe it’s not related to Ethernet driver as my 4.15.0-54 has the same "Can't disable ASPM" output at boot.

When trying to understand the comments about 18.04.3 and kernel 5 from ajgringo619 and guiverc, I came across this article that explains how can have your 18.04 upgraded to 18.04.3 but without having the 18.04.3 kernel 5.

That same article described how to get the latest 18.04.3 kernel by running this:

sudo apt install --install-recommends linux-generic-hwe-18.04 xserver-xorg-hwe-18.04

That generates an upgrade to kernel 5 and at least my computer boot with that kernel.

  • Super helpful of you, thanks so much. Useful background and specific solution which worked immediately. – Dave Skeet Sep 18 at 19:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.