0

I'm unable to get nvidia gpu running on my ubuntu 18.04.2 PC. I tried to do installation using apt-get install nvidia-driver-VERSION command with 391, 418 and 450 VERSION, but everytime without luck. I'm always getting black screen after logging in. I have the same with .run files from nvidia website. I also tried to blacklist nouveau default driver using https://askubuntu.com/a/1129961. After blacklisting ubuntu had problems with determining my screen resolution, so I assume nouveau got disabled.

My GPU: Gigabyte GTX 980 Ti.

  • You did everything wrong. Remove all Nvidia packages that you installed and disable all Nvidia PPAs. You can see all the installed Nvidia packages in Synaptic ( sudo apt install synaptic ). Then run sudo apt update. Finally run sudo ubuntu-drivers autoinstall && sudo reboot – karel Sep 14 at 17:13
  • and there is no 450 in the repos, the most curent afiak is 418. you can get 430 with the grapic drivers ppa but evne 435 is still in testing, it's only available in 19.10 testing – TrailRider Sep 14 at 17:16
  • 1
    The PPA is updated to 435.21; been running it for about a week. – ajgringo619 Sep 14 at 17:17
  • 1
    I have uninstalled apt-get purge nvidia*, disabled blacklisting of nouveau and everything started to run. I think I'm in good point to try again with something different, because I need official NVIDIA drivers to have CUDA running. – Adameeeeek Sep 14 at 17:26
  • 2
    @TrailRider - I'm running Mint 19.2, added the repo like this: sudo add-apt-repository ppa:graphics-drivers/ppa. Is this different than what comes with 19.04? – ajgringo619 Sep 14 at 17:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.