OpenShot is a free video editing software. In 2017, developpers updated it in a QT version. Recently I moved to Ubuntu 18.04 instead of 16.04 so I had no choice and had to use the new version of OpenShot. But, this version is paradoxaly slow and not precise at all. So can you help me to downgrade to the former version 1.4.3(for instance) instead of 2.x version(the new one) ?

I tested many alternative like Shotcut, Flowblade or Kdenlive but I prefere the old OpenShot. I know that what I ask for can create an unstable system but I really need it for school and if I can't install it on 18.04 I have to downgrade to 16.04.

Thanks by advance guys ! :) And sorry for my poor English, I'm French.

EDIT : I read this : Openshot Video Editor 1.4.3-1.2 - How to stop it auto updating to v 2.43 etc in 18.04 LTS but the person who sent the question didn't explained how he installed OpenShot and the dependances.


You can install whatever version you want by going to the repo you want and finding the needed .deb file.

For example for the OpenShot 1.4.3 you can download it from here

A quick way to install it:

wget https://launchpad.net/openshot/1.4/1.4.3/+download/openshot_1.4.3-1_all.deb -O openshot.deb
sudo dpkg -i openshot.deb

After that, if you have any missing dependencies run

sudo apt-get -f install

To install all the needed ones

  • Hi, thanks for help ! I ran commands you gave me and locked openshot package as explained in my former edit. But, when I run the "-f install" line, it says this : (I put it in an answer because it's too long) – Jean Dupré Sep 12 '19 at 18:03
  • No problem, if my answer did help you please not forget to mark it ;) – Giorgos Karapiperidis Sep 12 '19 at 18:07
  • I marked it, please read my former comment – Jean Dupré Sep 12 '19 at 18:09
  • The problem is that you are trying to install a package older of the one that is supported on Ubuntu 18.04 so it can't find the needed dependencies. Either you should find the supported distro and add it in the sources.list or you should go and download one by one the packages needed. – Giorgos Karapiperidis Sep 12 '19 at 18:21
  • How can I know the right dependancy ? And where can I find them ? Sorry, I'm a new Ubuntu user so I'm such a noob – Jean Dupré Sep 12 '19 at 18:42

when I run : sudo apt-get -f install It give back : Lecture des listes de paquets... Fait Construction de l'arbre des dépendances
Lecture des informations d'état... Fait Correction des dépendances... a échoué. Les paquets suivants contiennent des dépendances non satisfaites : openshot : Dépend: melt mais il n'est pas installé Dépend: python-httplib2 mais il n'est pas installé Dépend: python-imaging mais il n'est pas installable Dépend: python-mlt5 mais il n'est pas installable ou python-mlt3 mais il n'est pas installable ou python-mlt2 mais il n'est pas installable Dépend: python-pygoocanvas mais il n'est pas installable Dépend: python-xdg mais il n'est pas installé Dépend: python-support (>= 0.90.0) mais il n'est pas installable Recommande: openshot-doc mais il n'est pas installé E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état. E: Impossible de corriger les dépendances

You can use google translate or reverso to see what it means, because I don't want to give you a broken translation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.