0

I'm a new user to Ubuntu and this is my last resort to try and fix my computer. I hope someone can help me.

I have a Dell Inspiron 15 5000 , Intel core i3-1080p. Its brand new and it came with Windows but I have since installed Ubuntu and have been using it fine for I guess over a month. Everything worked fine, the installation went perfect.

I wanted to change the purple default login screen to a picture or a different color, so I looked up if you could do it. You could, but it had to be done through the terminal thing. This is the tutorial I followed to change it: https://vitux.com/how-to-change-login-lock-screen-background-in-ubuntu/

I followed the instructions precisely and everything looked exactly as they said it would, but I had to restart it for everything to take effect. This made sense, but when I restarted it, it blinked the desktop once and now I'm stuck with a black screen that says "/dev/nvme0n1p2: clean" etc at the top, along with a bunch of other things like "started user manager for UID 121" and "started session c1 of user gdm". (I tried to add a photo of it to this post but it was too big apparently.)

The screen it's stuck on normally shows up when I start the computer, and then it will go to the desktop and work fine, but now it just stays there. I can't do anything with it. I've tried things like going through the GRUB menu, checking the boot menu, and nothing works. I've done so many different things I've lost count. I've called people, no one supports Ubuntu/Linux. I'm completely stuck. PLEASE HELP! I'm new to this and I leave for college tomorrow and this is my computer that i was going to use. I desperately need a solution.

  • You should be able to use ctrl-alt-f3 to switch to a prompt, from there you can login, become root and modify files, so you might be able to undo what you've done and then reboot. – Matthew Hegarty Sep 12 at 11:44
  • Yeah, I've tried that. It can't open the file that I changed so I can't reverse it. – emilyrae Sep 13 at 12:19
  • Can you boot using recovery mode, the second line in grub menu, or first line of sub-menu? Then edit file from terminal it should boot to. – oldfred Sep 15 at 13:56
  • I can go to grub menu and do recovery mode but there's no terminal to type anything into. It comes up with a purple screen and a little recovery menu and that's it. – emilyrae Sep 15 at 18:54
0

If you can get a prompt and become root you should be able to edit the file. I don't know your level of experience, but as root you can use sudo vi <file> to make changes (i.e. reverse the changes in the link you posted). You have to use vi and not gedit when working with the terminal. This should work as long as you completely reverse your previous changes.

If it doesn't work, you can boot using a 'Live CD' image, and then overwrite the file you changed with those from the live CD. Note that you should always back-up files (e.g. cp file file.bak) before making changes to avoid these kinds of issues.

As a last resort, then if you have root access you can mount an external disk or USB drive and back-up your files. Then you can safely re-install the OS.

I suggest that if this is all new to you then you should find a friendly Linux user to work through it with you (if you are at college now there will surely be someone who can help!)

Hope it works out.

  • So I found the file, and I changed it back to exactly what it was before but there's no way for me to save it? Before there was a save button and it's not here anymore. I've tried the ctrl + :w things but those don't do anything. And I rebooted it but it's still doing the same thing. – emilyrae Sep 15 at 19:34
  • Can you try again and edit the file in vi, then press Escape key, followed by :wq to save and exit. Type less ubuntu.css to view the file and confirm your changes are there (press 'q' to quit). If the changes are there, you can reboot with sudo reboot. Check out this link and scroll to the bottom for more info on editing with vi. – Matthew Hegarty Sep 16 at 13:35
0

I had to take the computer somewhere and wipe it completely clean. It's all good now! Thanks for the help.

New contributor
emilyrae is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.