3

I get this error message when I try to install libssl1.0.0'.

How can I solve it? I use Ubuntu 19.04

  • 2
    The package libssl1.0.0 was dropped from Ubuntu after 18.04. Newer releases of Ubuntu use the package libssl1.1. 18.04 has both packages. – user535733 Sep 12 '19 at 2:55
4

The results of rmadison libssl1.0.0 show that the libssl1.0.0 package was dropped from the default Ubuntu repositories after Ubuntu 18.04.

$ rmadison libssl1.0.0
 libssl1.0.0 | 1.0.1-4ubuntu3     | precise          | amd64, armel, armhf, i386, powerpc
 libssl1.0.0 | 1.0.1-4ubuntu5.39  | precise-security | amd64, armel, armhf, i386, powerpc
 libssl1.0.0 | 1.0.1-4ubuntu5.39  | precise-updates  | amd64, armel, armhf, i386, powerpc
 libssl1.0.0 | 1.0.1f-1ubuntu2    | trusty           | amd64, arm64, armhf, i386, powerpc, ppc64el
 libssl1.0.0 | 1.0.1f-1ubuntu2.27 | trusty-security  | amd64, arm64, armhf, i386, powerpc, ppc64el
 libssl1.0.0 | 1.0.1f-1ubuntu2.27 | trusty-updates   | amd64, arm64, armhf, i386, powerpc, ppc64el
 libssl1.0.0 | 1.0.2g-1ubuntu4    | xenial           | amd64, arm64, armhf, i386, powerpc, ppc64el, s390x
 libssl1.0.0 | 1.0.2g-1ubuntu4.15 | xenial-security  | amd64, arm64, armhf, i386, powerpc, ppc64el, s390x
 libssl1.0.0 | 1.0.2g-1ubuntu4.15 | xenial-updates   | amd64, arm64, armhf, i386, powerpc, ppc64el, s390x
 libssl1.0.0 | 1.0.2n-1ubuntu5    | bionic           | amd64, arm64, armhf, i386, ppc64el, s390x
 libssl1.0.0 | 1.0.2n-1ubuntu5.3  | bionic-security  | amd64, arm64, armhf, i386, ppc64el, s390x
 libssl1.0.0 | 1.0.2n-1ubuntu5.3  | bionic-updates   | amd64, arm64, armhf, i386, ppc64el, s390x

The results of apt search libssl show that the libssl package has been upgraded to libssl1.1 in Ubuntu 19.04 (and later). To install it open the terminal and type:

sudo apt install libssl1.1
| improve this answer | |
  • Or similarly use libssl1.0 which today leads to libssl1.0.2 – EliadL Dec 5 '19 at 13:30
  • 3
    Seems running sudo apt-get install libssl1.0 does nothing. In my case, it says 0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded. – Prince Odame Dec 7 '19 at 23:02
0

If you need libssl1.0.0 on anything after Debian 8 (Jessie), you'll need to update your apt sources before apt installing.

Adding the following lines to my dockerfile worked:

RUN echo "deb http://security.debian.org/debian-security jessie/updates main" >> /etc/apt/sources.list
RUN apt-get update -y && apt-get install -y --no-install-recommends \
    libssl1.0.0
| improve this answer | |
  • 1
    This is askUBUNTU.com Adding debian sources to a Ubuntu system is a very terrible idea. – MAV May 15 at 13:44
0

You need to understand why your package manager is trying to install libssl1.0.0. aptitude why libssl1.0.0 will tell you.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.