0

Trying to install the latest stable version of hplip in the hope that it will solve my trouble, I get errors about missing libraries:

warning: Missing REQUIRED dependency: libusb (libusb - USB library)
warning: This installer cannot install 'libusb' for your distro/OS and/or version.

How can I install all the missing dependencies in their right versions?

Alternatively, would you recommend any other model/manufacturer for a low-cost printer that simply works with Ubuntu 18.04?

marked as duplicate by Graham, karel, N0rbert, matt, Thomas Ward Sep 13 at 19:59

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Browse other questions tagged or ask your own question.