2

My system (Ubuntu 18.04.3) stuck on a black screen on this morning 11 september 2019. I just applied some normal update.. libsystemd0, systemd-sys, udev, some kernel update, ...

enter image description here

Failed to start Network Manager Dependency failed for Network Manager Wait Online

Black screen and stuck here. Unable to boot even in recovery mode! Tried also old kernel. Nothing work.

I read that other people have a similar problem.

Thanks in advance! Michael

3

Your issue most likely related to this Launchpad Bug #1843507.

The workaround is detailed in the comment #4 on the same thread (which has worked for many):

$ wget http://mirrors.kernel.org/ubuntu/pool/main/libi/libidn2/libidn2-0_2.0.4-1.1build2_amd64.deb
$ sudo dpkg -i libidn2-0_2.0.4-1.1build2_amd64.deb
$ sudo apt-mark hold libidn2-0

Also go through this comment #12, you might need to purge old package.

Edit: To bring the network interface up, go through this post, though I'm posting the solution here, as many people are having this issue today.

If you have an Ethernet cable connect the computer directly to the modem and then:

sudo nano /etc/network/interfaces

Note: Replace "eth0" with actual interface name like "enp0s3". You can find that out with command "ip a".

Append the following lines to the end of the file:

allow-hotplug eth0
iface eth0 inet dhcp

Ctrl+X to exit and Y to save. Then:

sudo ifdown eth0
sudo ifup eth0

You should get an internet connection. If you do not have a DHCP server use the following instead (if you don't know if you have a DHCP server, then you probably have one so nevermind the following):

iface eth0 inet static
address 192.168.1.5
netmask 255.255.255.0
gateway 192.168.1.254

Replacing the address, netmask and gateway values with the ones you are used to.

  • 1
    Okay but how to do wget without a working network... – spassvogel Sep 11 at 8:45
  • 1
    Thanks it works! I copied the file in a usb key because i had also no network. – MichaelB Sep 11 at 8:55
  • @spassvogel just added the workaround to bring the network up. – Jags Sep 11 at 9:25
  • Thank you very much! – spassvogel Sep 11 at 12:23
0

People using Ondrej packages, can find Ondrej's own fix here (just released): https://github.com/oerdnj/deb.sury.org/issues/1247#issuecomment-530268417

If you don't have the package stated in the fix, just run the following commands:

$ cd /tmp
$ wget http://ppa.launchpad.net/ondrej/php/ubuntu/pool/main/libi/libidn2/libidn2-0_2.2.0-2+ubuntu18.04.1+deb.sury.org+1_amd64.deb

... now you can just follow Ondrej's fix instructions.

After the fix I had to reboot, in order to get the same output as Ondrej.

However, as stated in the original question, the issue can cause serious networking problems after rebooting with the faulty package. If you haven't rebooted already, first implement the fix to prevent new problems.

Please note, the selected answer was a temporary fix, posted prior to Ondrej releasing the proper/final fix.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.