I installed CompizConfig-Settings-Manager and I put on all the settings I liked and had in 11.10, including the ability to drag my windows to the adjacent workspace. It's under the Desktop Wall section, on the Edge Flipping tab and I've checked "Edge Flip Move" and "Edge Flip DnD."

In 11.10, the movement was smooth between each workspace, and the window would still be "grabbed" in the same place. In 12.04, it's leaving the window behind and the mouse appears to be "grabbing" nothing, but I'm still holding onto the window, and I can still move and place it within the workspace (or indeed the previous workspace as it won't appear in the desired place until I drag the mouse all the way to the edge of the screen).

Any way to fix this? I'm running 12.04 beta 2.


Should work using the keyboard shortcut, Ctrl+Alt+Shift+D-pad (on the D-pad use the arrow key pointing to the direction of the destination workspace of the migrating window). That works in all Linux desktops that I've tried, whether it be Unity, Gnome Shell, Xfce, LXDE, etc. Tried it on Gnome Shell on Ubuntu 12.04 and still works (granted Gnome Shell stacks workspaces strictly on a vertical scale, but you should be able to use any direction if you have a workspace left, right, above and below the workspace you are currently on...diagonal directions work too).

enter image description here

  • Thanks, but I want to know how I can do it without the keyboard... Sometimes if my hands are full it's easier to just drag a window to the adjacent space rather than hit the shortcut. – Bill O'Dwyer Apr 2 '12 at 9:30
  • 1
    You can right-click on the title-bar of a window and go to Move to Workspace x, unless you have a single-button mouse it's likely the easiest way to do it with the mouse. – titaniumtux Apr 2 '12 at 16:48
  • That doesn't seem to work in 12.04... Or maybe one of my compiz settings has switched that off. Either way, that's not what I want to do. I managed to do it in 11.10, so it should be simple. – Bill O'Dwyer Apr 10 '12 at 13:00
  • Oh? Did you try Alt+Space (with any window open)? That's the menu I'm talking about when right-clicking on the window's title bar. If you cannot see Movie to Workspace ... or Move to Another Workspace, please grab a screenshot after doing an Alt+Space to show me that it "doesn't seem to work in 12.04". – titaniumtux Apr 10 '12 at 19:51
  • Precisely nothing happens after pressing it. A screenshot would just show you a lovely picture of Chromium. The point is moot in any case, as your solution is not what I want to achieve. – Bill O'Dwyer Apr 11 '12 at 10:39

This is a known bug: https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/965577

Read the comments, there are some almost-solutions provided.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.