I have a Lenovo Y560 laptop on which I installed Windows 7 and Ubuntu 11.10 as dual boot. Due to some reason I had to recover the boot loader using bootrec.exe /fixmbr and bootrec.exe /fix boot. It created one partition of size 198 MB named "tet" and both Ubuntu and Windows were working fine.

Yesterday while making some changes in the partition table I deleted that "tets" partition and after reboot I'm getting the following error

Error: unknown filesystem
grub rescue>

I tried to boot from the Windows installer CD, but it get stuck at "Starting Windows", so I am not able to run the commands I have mentioned earlier and when I tried to boot from Ubuntu 11.10 (Oneiric Ocelot), it got stuck at this error:

Memory full
Can't kill any more process.

How can I fix this problem?


You should try reinstalling GRUB with Boot-Repair.

  1. Make a new Ubuntu Live CD and Boot from it.

  2. Install boot-repair using these commands:

    sudo add-apt-repository ppa:yannubuntu/boot-repair

    sudo apt-get update

    sudo apt-get install -y boot-repair


enter image description here

Click "Recommended repair". This will reinstall GRUB in the adequate disk(s). Then reboot.


You have deleted partition containing grub and windows 7 boot manager. I am afraid there is no other way except repair the mbr. If ubuntu boot was successful try with "boot-repair" tool (See here) or use windows 7 disk.


Burn a Super Grub2 Disk, then boot from it, choose to scan for operationg systems, start Ubuntu and log in. Then execute the command sudo grub-install /dev/sdX where X stands for a letter you can look up with sudo fdisk -l or in the disk utility - you need to find the Hard Disk from which you boot and then you'll see something like "Device Name: /dev/sda2" (The number at the end has no importance for this).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.