0

I wanted to connect remotely via RDP or VNC to an Ubuntu server with xubuntu-desktop installed. I tried the last 12h to fix this.

I installed both services and started them up and checked if they are active. RDP wasn't complicated an for VNC I followed some more advanced instructions for gnome.

I checked ports 3350, 3389, 6001 and 5901. All are on "listening".

When I try to connect via Windows Remote Desktop I get to this log in screen (link down below) but if I log in with a user account it just crashes during the setup of the connection.

No matter if I select some other methods than xorg (for example: xvnc, x11rdp, any-vnc or session-man) the log always says "failed" for some reason or it crashes.

Screen shot

Connecting via VNC with an android-vnc-viewer app (x.x.x.x:5901) I get to a grey screen with a cursor and can move it around but I can do nothing else.

Same result when I choose the vnc-any option at the login screen in the pic above.

Settings I used here:

  • ip: 127.0.0.1
  • port: 5901
  • vnc serverpw: X

I get to the grey screen with cursor and I can see the cursor of the android-vnc-viewer app moving.

  • The "grey screen with a cursor" sounds like you are getting X running but no desktop manager or or window manager. On a modern system the desktop manager (e.g. Gnome) would probably be what you hope and expect. – tripleee Sep 10 '19 at 4:38
0

seems to be the same issue as 18.04.3 LTS XRDP "login failed for display: 0"

there is a known issue with Ubuntu 18.04.2 and 18.04.3 and xrdp package found in the repository...When you install xrdp from repository on ubuntu 18.04.2 and later, the package needs xorg-xserver-core packages while these point releases have the xorg-xserver-core-hw* packages installed

You have to either

Best option - Install the new xorgxrdp-hwe-18.04 package

Install the new xorgxrdp package by issuing the following command

sudo apt-get install xorgxrdp-hwe-18.04

This should fix your issue

Downgrade xserver-xorg-core packages

  • downgrade xorg-xserver-core-hw* packages to xorg-xserver-core packages and then install the xorgxrdp package

More info on http://c-nergy.be/blog/?p=13390

Unofficial xrdp packages compatible with Ubuntu 18.04.3

  • use unofficial xrdp pacakge that can be used against Ubuntu 18.04.3

more info at http://c-nergy.be/blog/?p=13455

perform a scripted installation

  • use one of the xrdp installer script to automate the installation

hope this help Till next time

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.