0

I'm running 18.04 and need to connect my laptop to a WPA2 Enterprise network at my school that I'm fairly sure uses MSCHAPV2 with PEAP and no CA certificate. When I connect with the credentials that work fine with Windows and on my iPhone, it fails to authenticate as if my password is wrong. I've tried adding my ID to anonymous ID, which failed. I've tried no PEAP as well as a couple other security types, no dice. I've seen some old solutions but they seem to break compatibility with regular wpa2 networks, which is a deal breaker for me as I need seamless switching to my home network. Compounding my issues, I don't have access to gnome settings as I run the deepin desktop. lshw shows my wireless card as being an Intel Dual-Band Wireless AC 3168NGW [Stone Peak], whatever that means. Any help is welcome!

  • Do you have some sort of gui network manager that you use to connect to wifi networks with? Like this – SHawarden Sep 10 '19 at 2:16
  • That exact one would be the one I'm using – NerdyKyogre Sep 10 '19 at 12:32
0

I've just found the solution and it was the stupidest thing. Apparently GNOME Network Manager (The one I was using) loads credentials into memory when you input them. When it connects to enterprise networks, it will fail when it tries to read the credentials off the boot drive, and act as though the credentials are wrong because it didn't input any. The solution? Open "Connection Settings", then edit the connection, but don't do anything. Immediately close out of the connection editor and it will save your credentials properly. Then reconnect, input them again when prompted, and it will connect without issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.