1

Intermittently, my Dell Inspiron 13 with Ubuntu 18.04 doesn't let my keyboard work after suspend. There is no pattern that I can discern. Touchpad still works. Touchscreen still works, allowing me to still use the touch-keyboard to login - from there, I have to close all programs, restart the system, in order to get the keyboard working again.

I have tried switching to LightDm - it doesn't work. I have tried working with GRUB_CMDLINE_LINUX or to GRUB_CMDLINE_LINUX_DEFAULT - it doesn't work. I have tried various solutions to do with NVIDIA drivers - they don't work.

I am now at the point where, if I can not find a resolution to this problem, I will switch to a completely different Linux OS, despite having worked with various versions of Ubuntu over a decade.

I simply cannot do my job with an OS that makes the simple process of suspend/restore ineffective.

Solutions very, very welcome.

  • Have you tried the 18.04 HWE? (sudo apt install --install-recommends linux-generic-hwe-18.04 xserver-xorg-hwe-18.04.) It contains various improvements for Dell XPS 13 suspend issues but I cannot say for Inspiron as I don't have one. – B.Tanner Sep 9 at 12:02
  • I got: "Reading package lists... Done Building dependency tree Reading state information... Done linux-generic-hwe-18.04 is already the newest version (5.0.0.27.84). xserver-xorg-hwe-18.04 is already the newest version (1:7.7+19ubuntu8~18.04.2). 0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade." – Pepe Lebuntu Sep 9 at 12:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.