0

I wanna install Python 2.6 in Ubuntu 18.04, because when i install Chrome Remote Desktop, i got this error :

sudo dpkg -i chrome-remote-desktop_current_amd64.deb

The result is :

(Reading database ... 264805 files and directories currently installed.)
Preparing to unpack chrome-remote-desktop_current_amd64_.deb ...
Unpacking chrome-remote-desktop (77.0.3865.32) over (77.0.3865.32) ...
dpkg: dependency problems prevent configuration of chrome-remote-desktop:
 chrome-remote-desktop depends on xvfb-randr | xvfb; however:
  Package xvfb-randr is not installed.
  Package xvfb is not installed.
 chrome-remote-desktop depends on xbase-clients; however:
  Package xbase-clients is not installed.
 chrome-remote-desktop depends on python (>= 2.6); however:
  Package python is not installed.
 chrome-remote-desktop depends on python-psutil; however:
  Package python-psutil is not installed.

dpkg: error processing package chrome-remote-desktop (--install):
 dependency problems - leaving unconfigured
Processing triggers for ureadahead (0.100.0-21) ...
Processing triggers for systemd (237-3ubuntu10.25) ...
Errors were encountered while processing:
 chrome-remote-desktop

after suggestion by @Kulfy, sudo apt install -f, and i install again, the result is :

 chrome-remote-desktop : Depends: python (>= 2.6) but it is not going to be installed
                         Depends: python-psutil but it is not going to be installed
                         Recommends: xvfb-randr but it is not installable
E: Unable to correct problems, you have held broken packages.

But when i install python or python2 :

 python : PreDepends: python-minimal (= 2.7.15~rc1-1) but it is not going to be installed
          Depends: python2.7 (>= 2.7.15~rc1-1~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

My python version :

Python 3.7.3

My Python Location :

python: /usr/bin/python3.6m /usr/bin/python3.6 /usr/lib/python3.6 /usr/lib/python3.7 /usr/lib/python2.7 /etc/python3.6 /etc/python2.7 /usr/local/lib/python3.6 /usr/include/python3.6m /usr/share/python /home/reigin/anaconda3/bin/python3.7m-config /home/reigin/anaconda3/bin/python /home/reigin/anaconda3/bin/python3.7 /home/reigin/anaconda3/bin/python3.7m /home/reigin/anaconda3/bin/python3.7-config

Thanks for help..

  • 2
    It depends on python>= 2.6. That mean 2.7 should also satisfy the dependency. You can install Python 2.7 by simply running sudo apt install python or you can install all left dependencies using sudo apt install -f – Kulfy Sep 9 at 7:59
  • The following packages have unmet dependencies: python : PreDepends: python-minimal (= 2.7.15~rc1-1) but it is not going to be installed Depends: python2.7 (>= 2.7.15~rc1-1~) but it is not going to be installed E: Unable to correct problems, you have held broken packages. – Budi Mulyo Sep 9 at 8:07
  • What is the output of apt-cache policy python-minimal? – Kulfy Sep 9 at 8:09
  • python-minimal: Installed: (none) Candidate: 2.7.15~rc1-1 Version table: 2.7.15~rc1-1 500 500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages – Budi Mulyo Sep 9 at 8:13
  • 1
    Possible duplicate of How do I restore the default repositories? – N0rbert Sep 9 at 16:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.