2

Was following the instructions on this page but got stumped on the second step:

Using bridge-utils

$ sudo apt-get install bridge-utils

In a bridged setup, it is required that we assign the IP address to the bridged interface. Configure network interfaces so that they persist after reboot:

$ sudo vi /etc/network/interfaces

iface xenbr0 inet dhcp   bridge_ports eth0
iface eth0 inet manual```

Starting version 17.10 (in 2017), Ubuntu moved to netplan. So, these instructions are out of date. (The last update is 2015.) No telling how much more of the wiki's directions are out of date.

Edit: Additionally, the only file in the directory is /etc/netplan/50-cloud-init.yaml and when I nano it, the following message appears at top:

# the datasource.  Changes to it will not persist across an instance.
# To disable cloud-init's network configuration capabilities, write a file
# /etc/cloud/cloud.cfg.d/99-disable-network-config.cfg with the following:
# network: {config: disabled}

I'm taking it to mean that editing this file won't do any good? Not sure.

How does one install and configure Xen Project on 18.04?

1

The pertinent section relating to /etc/network/interfaces looks like this:

auto lo eth0 xenbr0 
iface lo inet loopback

iface xenbr0 inet dhcp   
    bridge_ports eth0

iface eth0 inet manual

Which in Netplan's /etc/netplan/config.yaml would look something like:

network:
  version: 2
  renderer: networkd
  ethernets:
    eth0:
      dhcp4: no
  bridges:
    xenbr0:
      dhcp4: yes
      interfaces:
        - eth0

Bear in mind that your interface names will probably have changed to match the newer, more consistent, naming scheme, so eth0 will probably more likely be enxNNNNN or enoN or some such.

Then you do the usual sudo netplan generate to check, and sudo netplan apply when you're sure it's correct.

  • Thanks for that. And then we have to hope that the rest of the lengthy instructions will match up with 4 years of progress and changes. Really feels like it's time for an updated instruction set. – Togar Sep 9 at 14:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.