I recently got a new laptop (a Dell Inspiron 15 5000) and have been experiencing stability issues with the wireless connection ever since I installed Ubuntu 18.04. The WiFi will disappear seemingly at random for somewhere between 30 seconds and one minute, then reappear. I have been unable to make it function any quicker by restarting the adapter using ifconfig

The issues are very similar to those described in this askubuntu question. I checked /var/log/syslog as suggested in this bug on Launchpad and did indeed find entries with avahi-daemon[xxx]: Withdrawing address record for xx.xx.xx.xx on interface_name. The suggested solution to disable ipv6 and reboot did not solve the issues.

I am unsure how to properly diagnose the issue and progress from here.

I have tried pinging various addresses while the WiFi is not working, all of which have resulted in the following message: ping: [xxx]: Name or service not known.

Likewise, rfkill list yields the following when the WiFi is not working:

1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

Some system information:

lspci -v:

    Subsystem: Dell QCA9377 802.11ac Wireless Network Adapter
    Flags: bus master, fast devsel, latency 0, IRQ 141
    Memory at c2000000 (64-bit, non-prefetchable) [size=2M]
    Capabilities: <access denied>
    Kernel driver in use: ath10k_pci
    Kernel modules: ath10k_pci

uname -a: Linux mia 5.0.0-27-generic #28~18.04.1-Ubuntu SMP Thu Aug 22 03:00:32 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

  • Did you also try solution of comment 42? bugs.launchpad.net/ubuntu/+source/avahi/+bug/1586528/comments/… – AlexOnLinux Sep 14 '19 at 9:36
  • 1
    I wanted to but apt told me that'd remove network-manager and a bunch of other packages I need as well, so I didn't want to go along with that. – miestasmia Sep 14 '19 at 15:10
  • did u ever use the command line to connect to the wifi? I mean stop all services that might interfere NetworkManager networking dhcpcd and connect via wpa_supplicant and obtain an ip manually or via dhclient. systemctl stop NetworkManager.service networking.service dhcpcd.service wpa_supplicant.service and than wpa_supplicant -c ssid.conf -i wlan0 and when connected dhclient wlan0 or ip addr add broadcast dev wlan0 && ip route add default via dev wlan0 and perhaps echo nameseever > /etc/resolv.conf – AlexOnLinux Sep 15 '19 at 16:47
  • Of course you have to adjust the ip and interface names acordingly. This way you might circumvent the bug, idk. – AlexOnLinux Sep 15 '19 at 16:52
  • I tried disabling network manager and using wicd instead. Unfortunately the issues persist and I've been unable to debug any further. I tried opening the connection info modal of wicd-gtk and the only useful piece of information is that RX drops to 0 while TX remains at about 1KB/s. I have a suspicion that it might be a kernel driver issue. – miestasmia Sep 20 '19 at 19:25

I've found that many Wifi related issues can be resolved by disabling the power management.

Here's how I do it:

Create: /etc/network/if-up.d/wifi-powerman-off
Enable: chmod +x /etc/network/if-up.d/wifi-powerman-off

Replace interface name


WLAN_IFACE=<<interface name>>

if [ ! -x $IWCONFIG ]; then
    exit 1

if [ "$IFACE" = $WLAN_IFACE ]; then
    $IWCONFIG $IFACE power off
  • Thank you for your answer. I've made the suggested changes and will report back whether the issue continues within the next day. – miestasmia Sep 12 '19 at 11:58
  • Unfortunately the issue remains. – miestasmia Sep 12 '19 at 12:43
  • 1
    Good luck finding a final remedy. As the above hasn't worked, you might want to investigate if there is a Github repo with a driver for the underlying chipset. I've had to do that with a number of Edimaxx devices. – Mark Sep 12 '19 at 15:28
  • I'm putting the bounty on this, not because it has resolved the issue but because it's expiring and this is the answer that got me the closest. – miestasmia Sep 18 '19 at 19:20
  • i assume doing this (if it works) has some effect on battery life? – Michael May 16 '20 at 1:28

From the accepted answer on this question:

You can try:

I think I fixed it. The problem probably originated from my router settings. When I changed from 802.11n+g+b to 802.11n+g the connection seems stable. Although over time I changed quite a lot of setting in Ubuntu and my router, this seemed to do the trick.

If the answer doesn't work notice how the question uses journalctl -xe when the connection drops to report errors. Try this on your system and update your own question with your error messages.

  • Thank you for your reply. I can see that my router is set to 802.11n, not n+g+b or n+g. I'm not sure if this could be an issue. I have no option to change this setting as my ISP provided the router and locked. If necessary I can connect it over rj42 to a router of my own if you believe this might make a difference. I tried checking journalctl when the connection dropped and couldn't find anything related to the drop except various applications complaining about being unable to connect to their servers. – miestasmia Sep 16 '19 at 6:20
  • @miestasmia I think you meant RJ45 and not rj42? That said it might be worthwhile asking the ISP if network outages could be caused on their end and not your own. – WinEunuuchs2Unix Sep 16 '19 at 10:57
  • I did indeed mean rj45. The outages are specific to this device so it's not my ISP's fault. – miestasmia Sep 16 '19 at 15:37
  • I don't even see any option in my router to disable "b" when "g" is in use. The 2.4Ghz band just says "b/g/n" while the 5Gz band says "a/n/ac". However, I see the issue regardless of which netowrk I am connected to, so I don't know if there is a similar issue on the 5Ghz side or what. – Michael May 16 '20 at 1:21

Just run this command:

$ sudo service network-manager restart 

It will restart all the services of wired or wireless connections.

  • Job for NetworkManager.service failed because a timeout was exceeded. See "systemctl status NetworkManager.service" and "journalctl -xe" for details. I looked at those two but didn't see anything helpful. – Michael May 16 '20 at 1:27

Solved! After trying multiple options many times, I:

  1. Went into the BIOS (F2 on Dell splash screen)
  2. Went into the Wifi section. It was already "Enabled".
  3. Turned it off (and pressed apply).
  4. Turned it back on (and pressed apply).

Now all is good again!

  • The problem hasn't returned? In my case, I can simply disconnect and reconnect to the same WiFi and it fixes the problem... for a few hours. – Michael May 16 '20 at 1:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.