0

My situation:

In all cases:

output1

$  juju deploy -n 3 ceph-osd --storage osd-devices=32G,2 --storage osd-journals=8G,1

Located charm "cs:ceph-osd-291".
Deploying charm "cs:ceph-osd-291".

I also tried:

output2

$ juju deploy -n 3 ceph-osd --storage osd-devices=ebs,32G,2 --storage osd-journals=ebs,8G,1
Located charm "cs:ceph-osd-291".
Deploying charm "cs:ceph-osd-291".
ERROR cannot add application "ceph-osd": pool "ebs" not found

I looked up my default storage pool on maas and it's default, I tried to use that pool and I received the same output as above output #2, so I eventually went with output #1

$ juju status ceph-osd

Model                         Controller                    Cloud/Region   Version  SLA          Timestamp
conjure-charmed-kubernet-7b6  conjure-up-01-14b  01  2.6.5    unsupported  12:05:18+10:00

App       Version  Status   Scale  Charm     Store       Rev  OS      Notes
ceph-osd           waiting    0/3  ceph-osd  jujucharms  291  ubuntu

Unit        Workload  Agent       Machine  Public address  Ports  Message
ceph-osd/6  waiting   allocating  20                              waiting for machine
ceph-osd/7  waiting   allocating  21                              waiting for machine
ceph-osd/8  waiting   allocating  22                              waiting for machine

Machine  State    DNS  Inst id  Series  AZ  Message
20       pending       pending  bionic      failed to start machine 20 (failed to acquire node: No available machine matches constraints: [('agent_name', ['93d500ee-7e14-4ece-81ae-69137d451f3a']), ('storage', ['root:0,18:32,19:32,20:8']), ('zone', ['default'])] (resolved to "storage=root:0,18:32,19:32,20:8 zone=default")), retrying in 10s (2 more attempts)
21       pending       pending  bionic
22       pending       pending  bionic

afaik, the issue is in the following if i'm not mistaken:

failed to start machine 20 (failed to acquire node: No available machine matches constraints: [('agent_name', ['93d500ee-7e14-4ece-81ae-69137d451f3a']), ('storage', ['root:0,18:32,19:32,20:8']), ('zone', ['default'])] (resolved to "storage=root:0,18:32,19:32,20:8 zone=default"))

But also, I can see that

I know that I add the storage pool names correctly as per https://maas.io/docs/kvm-host-storage-pools

And I noticed as per:

The format for the --storage option is ,,. The storage pools available are dependent on and defined by the backing cloud. However, by omitting the storage type, the default pool for that cloud will be chosen (E.g. for AWS, the default pool is EBS storage).

So it could be setting the wrong storage pool if I used output #1?

I am stuck and not sure how I can proceed

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.