2

I was running Minecraft flawlessly until a week ago on Ubuntu 14.04 with Java 1.8. Now Minecraft won't launch. I have searched and tried many things. Here is the launcher log with 1.8 installed

Getting syncinfo for selected version
Queueing library & version downloads
Unhandled exception in thread Thread[pool-2-thread-2,5,main]
com.google.gson.JsonSyntaxException: duplicate key: null
at com.google.gson.internal.bind.MapTypeAdapterFactory$Adapter.read(MapTypeAdapterFactory.java:191) ~[Minecraft.jar:?]
at com.google.gson.internal.bind.MapTypeAdapterFactory$Adapter.read(MapTypeAdapterFactory.java:146) ~[Minecraft.jar:?]
at com.google.gson.internal.bind.ReflectiveTypeAdapterFactory$1.read(ReflectiveTypeAdapterFactory.java:93) ~[Minecraft.jar:?]
at com.google.gson.internal.bind.ReflectiveTypeAdapterFactory$Adapter.read(ReflectiveTypeAdapterFactory.java:172) ~[Minecraft.jar:?]
at com.google.gson.Gson.fromJson(Gson.java:795) ~[Minecraft.jar:?]
at com.google.gson.Gson.fromJson(Gson.java:761) ~[Minecraft.jar:?]
at com.google.gson.Gson.fromJson(Gson.java:710) ~[Minecraft.jar:?]
at com.google.gson.Gson.fromJson(Gson.java:682) ~[Minecraft.jar:?]
at net.minecraft.launcher.updater.RemoteVersionList.getCompleteVersion(RemoteVersionList.java:32) ~[launcher.jar:1.6.89-j]
at net.minecraft.launcher.updater.MinecraftVersionManager.getLatestCompleteVersion(MinecraftVersionManager.java:213) ~[launcher.jar:1.6.89-j]
at net.minecraft.launcher.updater.MinecraftVersionManager.getLatestCompleteVersion(MinecraftVersionManager.java:37) ~[launcher.jar:1.6.89-j]
at com.mojang.launcher.game.runner.AbstractGameRunner.playGame(AbstractGameRunner.java:67) ~[launcher.jar:1.6.89-j]
at net.minecraft.launcher.game.GameLaunchDispatcher$1.run(GameLaunchDispatcher.java:111) ~[launcher.jar:1.6.89-j]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) ~[?:1.8.0_202]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) ~[?:1.8.0_202]
at java.lang.Thread.run(Thread.java:748) [?:1.8.0_202]

I also tried the new Minecraft.deb launcher from the official site, which installed Java 1.12, but it wouldn't launch either, and the launcher log output was similar. It seems like everything is telling me to get 1.8 installed, which I believe I have successfully, but no luck with Minecraft. Any advice? Thanks.

1

You have a duplicate key in one of your JSON files, eg. something like this:

{
  "foo": 1,
  "bar": 2,
  "foo": 3
}
| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.