I have followed; https://warlord0blog.wordpress.com/2018/03/27/access-dfs-shares-from-linux/

Through this I can mount the cifs share manually, however when I try to mount it in the fstab via kerberos;

//windows/share/filepath /home/Drive cifs user,uid=me,gid=metoo,vers=3.0,rw,sec=krb5 0 0

I get;

➜ ~ sudo mount -a
mount error(2): No such file or directory Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)


I have now changed it to; //windows/share/filepath /home/Drive cifs _netdev,sec=krb5,noserverino,user,uid=myname,cruid=myname,gid=mygroup,rw 0 0

It now fails on boot but works after I run; sudo mount -a

  • Is this a typo //windows/sahre/filepath ( sahre vs share )? – Thomas Sep 7 '19 at 11:00
  • doesn't really matter, it's not the real filepath :-) – eekfonky Sep 7 '19 at 11:28

I have found a way that has worked for me on Ubuntu 18.04;

sudo vim /etc/nsswitch.conf

Add wins to the line below; Change from;

hosts:          files mdns4_minimal [NOTFOUND=return] dns myhostname


hosts:          files wins dns mdns4_minimal [NOTFOUND=return] dns myhostname

Save & quit

sudo vim /etc/request-key.conf

Changed the -c (as it's deprecated anyway) option to -t on the cifs.spnego line:

create cifs.spnego * * /usr/sbin/cifs.upcall -c %k


create cifs.spnego * * /usr/sbin/cifs.upcall -t %k

Save & quit

Also had to add -t option to cifs.upcall in /etc/request-key.d/

sudo vim /etc/request-key.d/cifs.spnego.conf


create cifs.spnego * * /usr/sbin/cifs.upcall -c %k


create cifs.spnego * * /usr/sbin/cifs.upcall -t %k

Save & quit

sudo vim /etc/fstab

Append it as per;

<server address from above> <mount point locally> cifs _netdev,sec=krb5,noserverino,user,uid=<alias>,cruid=<alias>,gid=domain^users,rw  0 0

Save & quit Mount it with;

sudo mount -a

You'll now have access, it should also be persistent on reboot

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.