0

Ubuntu 16.04.6 LTS and trying to install ffmpeg.

$ sudo apt install ffmpeg
Reading package lists... Done
Building dependency tree       
Reading state information... Done
ffmpeg is already the newest version (7:4.1.3-0york1~16.04).
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 cuda-libraries-dev-10-1 : Depends: libcublas-dev (>= 10.2.1.243) but it is not going to be installed
 cuda-samples-10-1 : Depends: libcublas-dev (>= 10.2.1.243) but it is not going to be installed
 cuda-visual-tools-10-1 : Depends: libcublas-dev (>= 10.2.1.243) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

It says ffmpeg is already the newest version, which it is not (V1.4 is the most current one afaik). I tried checking ffmpeg version:

$ ffmpeg -version
The program 'ffmpeg' is currently not installed. You can install it by typing:
sudo apt install ffmpeg

Note: I looked over other posts and added this apt repo: sudo add-apt-repository ppa:jonathonf/ffmpeg-4

I was able to install ffmpeg using pip3 and that installed to /usr/local/lib/python3.5/dist-packages/ffmpeg.

Can anyone help with this problem?

3
  • 1
    A couple of things: 1. Did you run sudo apt-get -f install as it's telling you to do? 2. The phrase "newest version" in the output doesn't stand for the absolutely newest version of the application, but the newest version from the repositories you currently have added to your system.
    – pomsky
    Sep 7 '19 at 8:44
  • 1
    Possible duplicate of The following packages have unmet dependencies! Sep 7 '19 at 8:49
  • I did run that, but that throws a weird error: Preparing to unpack .../libcublas-dev Unpacking libcublas-dev (10.2.1.243-1) ... dpkg: error processing archive /var/cache/apt/archives/libcublas-dev_10.2.1.243-1_amd64.deb (--unpack): trying to overwrite '/usr/lib/x86_64-linux-gnu/libcublas_static.a', which is also in package nvidia-cuda-dev 7.5.18-0ubuntu1 dpkg-deb: error: subprocess paste was killed by signal (Broken pipe) Errors were encountered while processing: /var/cache/apt/archives/libcublas-dev_10.2.1.243-1_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1)
    – Santino
    Sep 7 '19 at 8:54
1

You can try to build this from sources

$ tar xjf ffmpeg-4.2.1.tar.bz2
$ cd ffmpeg-4.2.1

And use instructions from INSTALL.md file:

  1. Type ./configure to create the configuration. A list of configure options is printed by running configure --help.

    configure can be launched from a directory different from the FFmpeg sources to build the objects out of tree. To do this, use an absolute path when launching configure, e.g. /ffmpegdir/ffmpeg/configure.

  2. Then type make to build FFmpeg. GNU Make 3.81 or later is required.

  3. Type make install to install all binaries and libraries you built.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.