1

When I open GParted , the icon of GParted appear near cursor for 1 minute, but after that the icon disappears and GParted didn't open

but when I run it on terminal with this instruction

sudo gparted

GParted opens immediately.

I was had Ubuntu 11.10 and recently installed KDE on it .

3

It's a bug in gparted (to be precise, the wrapper around it, gparted-pkexec). If you run gparted-pkexec in the terminal, you'll see something like:

No protocol specified
No protocol specified

(gpartedbin:19659): Gtk-WARNING **: cannot open display: :0

Replace the contents of to use kdesudo instead of pkexec to work around this issue:

sudo tee /usr/bin/gparted-pkexec <<'EOF'
#!/bin/sh
kdesudo "/usr/sbin/gparted" "$@"
EOF

Update: this is a bug in PolicyKit combined with a condition in KDE ($XAUTHORITY is not set).

  • I entered this instruction in terminal. Even copy them into terminal . but it didn't worked for me :( – hamed Mar 30 '12 at 13:02
  • You should see the two lines in the middle coming back unchanged when executing it in the terminal. What happens if you execute gparted-pkexec in a terminal after doing this? You should get a password dialog from kdesudo. – Lekensteyn Mar 30 '12 at 13:26
  • Yeah, I see the two lines but When I run gparted-pkexec in terminal, I get this error /usr/bin/gparted-pkexec: 2: kdesudo: not found – hamed Mar 30 '12 at 13:33
  • Ooh, you have not a full KDE system (Kubuntu). Try substituting "kdesudo" for "gksu" for GNOME. – Lekensteyn Mar 30 '12 at 13:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.