0

I had everything working perfectly till yesterday night when today my Ethernet port stopped working all of a sudden. I did the following:

  1. Connected another laptop to the same LAN cable and LAN port combination: worked
  2. Connected the LAN cable with a Ethernet to USB adapter into my laptop's USB port: worked

Therefore, I can tell that the problem is with some settings in Ubuntu or with the Ethernet port in my laptop.

What can I do to fix this issue? I am using Ubuntu 18.04 on a similar laptop to this.

0

This was an outdated software issue. I fixed it by:

  1. Boot into Windows
  2. Fired up HP Support Assistant (my laptop was from HP, other companies might have different ways)
  3. Launch updates for BIOS version and for LAN drivers.
  4. Wait for 10-15 minutes for it to complete.

Restart the machine and now it works!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.