0

I have strange situation, maas won't boot my servers with 18.04 ubuntu, but if I repack initrd from gzip to lzma - it starts working. I had to change boot-resource "current" symlink to directory and make it immutable with chattr for a moment, just so boot-resource import/update won't overwrite my repacked initrd. But I'm baffled with this behavior. Any ideas?

0

I had this exact same problem earlier this month. Bootloops immediately after loading initrd on 2/3 of my blades, otherwise works fine. 16.04 loads fine.

I kid you not, my solution (after exhausting everything rational) was to tell maas to use the 18.04 hwe low latency kernel. This makes absolutely zero sense, but everything started working by the second deployment attempt.

It's very strange that such a problem

a) still exists with maas and the current LTS release

b) that the normal kernel works perfectly on 1/3 of my (as far as I know, identical) blades

c) that changing kernel type somehow fixes it.

It's interesting that you have an alternate solution. I wonder if the 18.04 low latency kernel selection alters the entire build such that the initrd is packed differently?

  • I have this problem with blades too, other servers work fine, but like you I have many blades that doesn't boot normally. We're using supermicro blades. I will try you "solution" too, as my "solution" leads to free disk space problem with snapshot download. – Albert Valiev Sep 16 at 10:19
  • Didn't help in my case, tried every kernel combination few times - reboot loop persists, so I turned off autoupdate for images and put my repacked initrd as main. – Albert Valiev Sep 19 at 9:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.