I just installed ubuntu 18.04.3 LTS 64b on an ASUS ZenBook 14 UX431FN-AN001T using both Intel and NVIDIA GeForce MX150.

I don't manage to use the nvidia graphic card and up to now, could use the laptop only booting with nomodeset in resolution 800x600 and there is no possibility to adjust the screen resolution to 1920x1080.

I installed the nvidia drivers (version 430, as suggested by the command ubuntu-drivers devices) from the "software & updates"/"Additional Softwares" panel (dkms status indicates : nvidia, 430.26 installed), and restarted the computer (with secure mode disabled).

After the command "prime-select nvidia": Booting without nomodeset I only get a black screen, and rebooting with nomodeset it blocks on a black screen with only a white underscore sign at upper left corner.

When using instead "prime-select intel", the booting has been successful once with nomodeset, but now blocks on a black screen with only a white underscore sign (with no explaination), while i still get a black screen without nomodeset.

I tried previously the fedora distribution and encountered the same issues, i tried to install the most recent nvidia-435 driver (indicated on the nvidia website as the ultimate driver for geforce mx150) downloading it directly from the nvidia website and ended up always with the black screen. I don't know how to proceed any further, someone can help?

Some more indications:

$ uname -a
Linux cel-asus 5.0.0-25-generic #26~18.04.1-Ubuntu SMP Thu Aug 1 13:51:02 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

$ dkms status
nvidia, 430.26, 4.15.0-58-generic, x86_64: installed
nvidia, 430.26, 5.0.0-25-generic, x86_64: installed

$ lspci -knn | grep "VGA|3D" -EA2
00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:3ea0]
    Subsystem: ASUSTeK Computer Inc. Device [1043:1ebe]
    Kernel modules: i915
01:00.0 3D controller [0302]: NVIDIA Corporation GP108M [GeForce MX150] [10de:1d12] (rev a1)
    Subsystem: ASUSTeK Computer Inc. Device [1043:1ebe]
    Kernel driver in use: nvidia

$ nvidia-settings

ERROR: Error querying enabled displays on GPU
       0 (Missing Extension).

ERROR: Error querying connected displays on
       GPU 0 (Missing Extension).

** Message: 16:34:08.100: PRIME: No offloading required. Abort
** Message: 16:34:08.100: PRIME: is it supported? no

ERROR: nvidia-settings could not find the
       registry key file. This file should
       have been installed along with this
       driver at
       rofiles-key-documentation. The
       application profiles will continue to
       work, but values cannot be
       prepopulated or validated, and will
       not be listed in the help text. Please
       see the README for possible values and
  • Please post output of uname -a; dkms status and lspci -knn | grep 'VGA|3D' -EA2 to your question. – Pilot6 Sep 2 '19 at 14:18
  • Just done it, and added the ERROR output of the nvidia-settings command that maybe can help? (the commands does anyway open a window with a few settings options) thanks for the help – celia Sep 2 '19 at 14:39
  • And what if you boot with the 4.15 kernel without nomodeset? – Pilot6 Sep 2 '19 at 14:40
  • booting with the 4.15 kernel without nomodeset i get a black screen (with prime-select nvidia) – celia Sep 2 '19 at 14:44
  • I have no ideas, maybe someone else will solve it. – Pilot6 Sep 2 '19 at 14:45

I had a similar problem with Nvidia graphics card in ubuntu.

You can try this

1) Remove all the drivers of Nvidia with the help of purge check here how to remove all Nvidia drivers How can I uninstall a nvidia driver completely ?. Then reboot the pc, this will solve your problem.

2) If that doesn't solve your problem then backup all your important data from ubuntu and get ready to reinstall ubuntu, but this time while reinstalling don't tick the option install third-party software then complete the ubuntu installation as usual.

  • Thanks, in the meantime I started a dist-upgrade to ubuntu 19.04, when it's done I'll try your suggestions. – celia Sep 2 '19 at 16:24
  • 1
    I tried both suggestions unsuccessfully, first purged the nvidia drivers, rebooting anr re-installing nvidia-prime and nvidia-driver. Then I tried to reinstall Ubuntu without ticking install third-party software and the install nvidia-prime and nvidia-driver, and got again the same black screen after installation of nvidia-prime and nvidia-driver (with and without nomodeset). – celia Sep 3 '19 at 17:41
  • I finally solved the issue that was linked to the edid handling of the 1920x1080 resolution of the screen – celia Sep 3 '19 at 17:43

I finally solved the issue of the black screen, following instructions found there: https://ubuntuforums.org/showthread.php?t=2420705

The solution is the following:

It's a problem with edid version 2.4

Here is the workaround:

  1. Download 1920x1080.bin from here

  2. Move it to /lib/firmware/edid/

  3. Edit /etc/default/grub and add this:

  4. Run sudo update-grub

  5. Restart the computer

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.