0

After a dual-boot Windows 10/Ubuntu 18.04 installation, it looked like the PC was booting straight to Ubuntu, without showing the GRUB menu, after a short pause. I had already run Boot Repair under Ubuntu and checked bcdedit under Windows.

It turned out, during boot I had to hit the Esc key when the screen turned Ubuntu-purple, in order to display the GRUB menu and be allowed to choose the OS to boot. Not pressing Esc, after a time-out, the PC would boot to the default (Ubuntu).

I don't want to have to hit Esc every time during boot: how can I have the boot process show the GRUB menu right away, with no need for me to hit Esc?

1

Couldn't comment @Fanta, but after turning off GRUB_TIMEOUT_STYLE setting I got another error, something about "Couldn't find hwmatch module".

I fixed it not by turning off the GRUB_TIMEOUT_STYLE setting, but setting it from hidden to menu

See more about that setting here in the GRUB manual on gnu.org.

0
  • Install and run Grub Customizer
  • From the General Settings tab, click on advanced settings
  • In the window that pops up, disable GRUB_TIMEOUT_STYLE (as per screenshot below)
  • Close, save and exit
  • Reboot to test

Grub Customizer settings dialog

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.