I'm trying to install driver for my newly bought USB Wifi adapter. I tried installing driver provided in the CD that came with the adapter, it gave me this error

error: implicit declaration of function ‘init_timer’; did you mean ‘_init_timer’? [-Werror=implicit-function-declaration]

The driver name in the provided cd is


so I tried installing all the driver available on internet with name of rtl8188EUS or rtl8188EU but nothing worked. Either they give an error like above or they just don't work. I think it is because my kernel version is


and they all work with some old kernel version. Please guide me how do get rtl8188EUS driver working on my Ubuntu 18.04.2 lts.

  • Find the driver's source code on GitHub and follow the build and install instructions there. Realtek is a really bad manufacturer, they don't maintain their drivers properly. – Velkan Sep 2 '19 at 8:50

You'll find a known to be working driver on this github:

First, undo what you did with provided CD
Then install the driver from github:

# Prepare
sudo apt update
sudo apt-get install -f
sudo apt-get dist-upgrade
sudo apt-get -y install dkms build-essential git

# Go install the driver 
mkdir ~/DriverBuild
cd ~/DriverBuild
git clone https://github.com/lwfinger/rtl8188eu.git
sudo dkms add ./rtl8188eu
sudo dkms build 8188eu/1.0
sudo dkms install 8188eu/1.0

If the network manager says: "Device is not ready"
Make sure you copied the firmware (rtl8188eufw.bin) to /lib/firmware/rtlwifi/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.