When I run the java -jar command it gives me this:

wolfgang@laptop1:~$ java -jar /home/wolfgang/Downloads/forge-1.12.2-
We appear to be missing one or more essential library files.
You will need to add them to your server before FML and Forge will run successfully.java.lang.ClassNotFoundException: net.minecraft.launchwrapper.Launch
    at java.net.URLClassLoader.findClass(URLClassLoader.java:382)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:349)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Class.java:348)
    at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.java:52)
    at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper.java:34)

First, try installing the Forge "Installer" .jar instead of the "Universal" .jar. You can download the Installer from Forge, make sure you're selecting the "Installer" option, not "Universal":


If that still doesn't help and you see the same error, you could try manually downloading the libraries required here:


Extract them to /libraries on your Minecraft server, then run the installation again:

java -jar forge*installer.jar

| improve this answer | |
  • 1
    thank you first option worked – WOLFGANG343 Sep 2 '19 at 5:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.