0

I have Lubuntu 18.04 on an EB1501P MiniPC and i usually have HDMI plugged into a TV.

Sometimes i need something else connected to the TV and swap out the HDMI. Leaving Lubuntu without a HDMI output.

That in itself does no harm. But if i reboot without HDMI in it i have no picture on VNC and my user do not AutoLogin to Lubuntu beacasue of missing display.

Computer = EB1501P 64bit

GPU = NVIDIA ION

Proprietary Drivers = 340.107

OS = Lubuntu LTS 18.04.3 64bit


I have tried to make a add to xorg.conf --allow-empty-initial-configuration and add a Virtual Desktop

nano /etc/X11/xorg.conf

Section "Device"
   Identifier     "Device0"
   Driver         "nvidia"
   VendorName     "NVIDIA Corporation"
   BoardName      "ION"
   Option      "UseEDIDDpi"         "false"
   Option      "DPI"                "96 x 96"
   Option "AllowEmptyInitialConfiguration"
EndSection

Section "Screen"
   Identifier     "Screen0"
   Device         "Device0"
   Monitor        "Monitor0"
   DefaultDepth    24
   Option         "Stereo" "0"
   Option         "metamodes" "1920x1080_60 +0+0"
   Option         "SLI" "Off"
   Option         "MultiGPU" "Off"
   Option         "BaseMosaic" "off"
   Option         "UseEdidDpi" "False"
   SubSection     "Display"
      Depth       24
      Virtual     1920 1080
   EndSubSection
EndSection

And The Screen can show a picture with no HDMI plugged in. But when i plug in HDMI in TV i get black screen saying "No Signal"


Then i have allso tried installing and configuring

xserver-xorg-video-dummy-hwe-18.04

and tried adding

nano /etc/X11/xorg.conf

Section "Device"
    Identifier  "Configured Video Device"
    Driver      "dummy"
    #Option "NoDDC" "true"
    #Option "IgnoreEDID" "true"
EndSection

Section "Monitor"
    Identifier  "Configured Monitor"
    HorizSync 31.5-48.5
    VertRefresh 50-70
EndSection

Section "Screen"
    Identifier  "screen0"
    Monitor     "Monitor0"
    Device      "Configured Video Device"
    DefaultDepth 24
    SubSection "Display"
        Depth 24
        Modes "1920x1080"
    EndSubSection
EndSection

And the Screen only shows picture om TV.


I have of course messed with many different attempts with these two configurations but for no avail. Sometimes it would show picture without HDMI in VNC but wouldten work on TV if plugged in. Other times i either could only acces TV or VNC image.


this is my origional xorg.conf created by nvidia-xconfig

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 390.77  (buildd@lcy01-amd64-022)  Thu Sep  6 07:51:39 UTC 2018

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "SAMSUNG"
    HorizSync       26.0 - 81.0
    VertRefresh     24.0 - 75.0
    Option         "DPMS"
    Option         "DPI" "96 x 96"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "ION"
    Option      "UseEDIDDpi"         "false"
    Option      "DPI"                "96 x 96"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "metamodes" "nvidia-auto-select +0+0 {AllowGSYNC=Off}"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    Option         "UseEdidDpi" "False"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

What do i need to do to be able to VNC into Lubuntu without out HDMI. And to use the same image on my TV if i suddenly plugin the Cable ?

Best regards and ty for reading Darkyere

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.