1

When I enter the command:

sudo apt install libstdc++6:i386

I get the output:

 The following packages have unmet dependencies:
 libstdc++6 : Breaks: libstdc++6:i386 (!= 8.2.0-1ubuntu2~18.04) but 8-20180414-1ubuntu2 is to be installed
 libstdc++6:i386 : Depends: gcc-8-base:i386 (= 8-20180414-1ubuntu2) but 8.2.0-1ubuntu2~18.04 is to be installed
                   Breaks: libstdc++6 (!= 8-20180414-1ubuntu2) but 8.2.0-1ubuntu2~18.04 is to be installed
 E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

This answer (https://askubuntu.com/a/1104999/772004) shows that 8.2.0-1ubuntu2~18.04 refers to the "bionic-updates" repository, while 8-20180414-1ubuntu2 refers to the "bionic" repository.

Why are these packages in conflict? What does it mean that a different package is "to be installed"? Finally, how can I resolve the issue?

Edit: I did figure out a solution. I needed to add the bionic-updates and bionic-security repositories to my sources.list file. Also, Sophos AV was causing some trouble with apt. Once I changed sources.list and uninstalled Sophos AV, I was able to update and resolve all dependency issues.

  • You didn't say what OS/release you are running, packages.ubuntu.com/… shows what each release expects but you have packages (thus sources) that don't match any; and what is your architecture; x86_64? – guiverc Sep 1 at 1:22
  • Is your system fully up-to-date? (Probably not.) – fkraiem Sep 1 at 2:06
  • 1
    By the way, when Apt says a package "is to be installed", it means it is the package you requested to be installed, or a dependency thereof. – fkraiem Sep 1 at 2:08
  • I'm running Ubuntu 18.04.2 LTS, and yes, its an x86_64 architecture. My settings say I'm up to date, but maybe I'm missing something. And thanks for the explanation. – enivium Sep 1 at 2:44
1

In order to fix this, I needed to edit my /etc/apt/sources.list file.

I had only the line:

deb http://archive.ubuntu.com/ubuntu bionic main universe restricted multiverse

and I needed to add the lines:

deb http://archive.ubuntu.com/ubuntu bionic-security main universe restricted multiverse
deb http://archive.ubuntu.com/ubuntu bionic-updates main universe restricted multiverse

to add the bionic-security and bionic-updates repositories. Afterward I still had some trouble, which turned out to be related to Sophos AV. After unintstalling Sophos AV,

sudo apt update
sudo apt upgrade

fixed all the dependencies.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.