0

After upgrading to Ubuntu my Samsung wifi Multifunction printer prints random characters regardless of the version of the suldr driver.

2 Answers 2

0

First install the suldr driver either by downloading it from the HP/samsung site, or via the https://www.bchemnet.com/suldr repository (see https://github.com/dorfsmay/laptop-setup-ubuntu-18.04/blob/master/idempotent/031-suldr-samsung-drivers). This is required to be able to use the scanner.

Then:

  • open a browser
  • navigate to localhost:631
  • click on "Printers" in top bar
  • click on name of the printer (Samsung...)
  • Click on the "Administration" drop down menu, and select "Modify Printer"
  • You'll be prompted for your user id and password, enter your Linux login credentials
  • select the first printer in "Discovered Network Printers", "Continue"
  • "Continue" again
  • select "Samsung XXXXX driverless cups-filters", "Modify Printer"

Now when you click again on "Printers" in the top bar, it should show "driverless" under "Make and Model"

0

That was happening to me when I was printing to my Samsung M2820-DW because linux was sending the print job driverless, but in raw mode. I'm not an expert, but the following worked for me, both in Ubuntu 18.04 and 20.04:

  1. Open Ubuntu Settings.
  2. Choose Printers from the left panel
  3. Up near the top right of the main window, click the Add button
  4. Your printer should show up in a list with and address of {bunch of hex digits}.local . Select that, and click the Add button in that window.
  5. The system may offer to download a driver. If so, accept it.

That's it. To check your work, point your browser at localhost:631 , and choose the Printers tab. The printer you added should show up as having a model something of the form, "Samsung M262x series, driverless, cups-filters 1.20.2" Print to that one. Do NOT print to the printer that has a model, "Local Raw Printer," even though it appears to be your Samsung. The latter is the one that prints reams of random characters.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.