2

I suddenly cannot connect to the Wi-Fi and it shows the below message in settings when the Wi-Fi is off, While at the same time, it recognizes the Wifi networks and connects to them when Wifi is on!

Please find below the card info that I got from the terminal using the command inxi -Fxz :

Network:   Card-1: Intel Wireless 3160 driver: iwlwifi bus-ID: 06:00.0
           IF: wlp6s0 state: down mac: <filter>
           Card-2: Realtek RTL810xE PCIE Fast Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 07:00.0
           IF: enp7s0 state: down mac: <filter>

Prior to posting this question, I spent several hours trying the solutions on other posts & none of them worked!

Here are some examples of the commands I tried:

Thank you

  • " it recognizes the Wifi networks and connects to them when Wifi is on!" Isn't this the expected behavior? We don't understand what the question is. Welcome to Ask Ubuntu. – chili555 Aug 31 '19 at 18:22
  • Hi Mate, 1- Is it normal to get this message when the Wifi is off? Am I not supposed to get a message that that says that the Wifi is off or something similar instead of (No WiFi Adapter found)? 2- even when it connects to the WiFi network, there is no internet and there is absolutely nothing wrong with the Wifi itself. – blazingamr Sep 1 '19 at 7:47
  • Sorry that I am not very much tech savvy, I do connect to Wifi but I had a question mark on the Wifi Icon before, But I disabled (Connectivity Checking) in Stettings and it went away, still no internet. The Wifi is working fine on other devices & even on windows on the same laptop. – blazingamr Sep 1 '19 at 9:46
  • When the wireless appears to be connected, run the wireless script from here and paste the results here: paste.ubuntu.com and give us the link. askubuntu.com/questions/425155/… – chili555 Sep 1 '19 at 12:50
  • paste.ubuntu.com/p/n28vFKngqY – blazingamr Sep 1 '19 at 13:24
1

We note that several of the "solutions" that you have tried involve compiling a driver for Realtek hardware. As we see from your lspci, your wireless driver is iwlwifi. You have an Intel wireless device, not a Realtek. Any driver you install for a Realtek device will be ineffective.

It is fairly common for new users of Ubuntu to read a forum post about solving a wireless issue and then blindly apply it to their system. They are usually disappointed when there is no improvement. While it is not dangerous to add a new wireless driver that your system doesn't even use, it is futile if you don't know what driver you have. I urge all Ubuntu users to determine what wireless driver they have before applying any fixes to the system. You can do so with the terminal command:

lspci -nnk | grep 0280 -A3

After determining, for example, that you are using the driver iwlwifi, if you are having difficulties, search only for answers applicable to iwlwifi, such as "slow wireless" iwlwifi or "connection drops" iwlwifi.

We also notice from your paste that you are running Network Manager and ConnMan. It is not surprising that you are getting confusing messages from Network Manager. It is telling you that it doesn't know what is happening as it is no longer in charge.

As ConnMan is really designed for embedded applications, Raspberry Pi, doorbells, routers, et al, and you appear to have an ordinary desktop installation, I suggest that you remove ConnMan. It is obviously not doing a good job for you.

sudo apt purge connman

Next, your resolv.conf file is faulty. Let's fix it:

sudo rm /etc/resolv.conf
ln -s /run/systemd/resolve/stub-resolv.conf /etc/resolv.conf

Reboot and let us hear the result. Do you connect and reach the internet?

  • Solved, dear. Thank you very much for the detailed answer, you rock, man. – blazingamr Sep 2 '19 at 17:06
  • If my answer has been helpful, please accept it. askubuntu.com/tour – chili555 Sep 2 '19 at 19:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.