1

From what I can gather from searching around, there is an issue with Ubuntu 18.04 LTS clipboard and Wayland video. However, I'm running x11:

$ echo $XDG_SESSION_TYPE
x11

So my issue is this; when using copy and paste, for example in LibreOffice, the formula does not copy into the clipboard, only the result, in all cases. I've removed and reinstalled LibreOffice, removed my LibreOffice profile, and tried a newer version of it using Snap install.

I have another PC running the same installation. This does not exhibit the fault. Therefore it seems to me that there may be a fault with the clipboard element of KDE.

Is there any way of removing and reinstalling the clipboard? Or repairing it in some way?

Does anyone have any other suggestions?

EDIT

I should like to point out that this loss of format occurs in documents too. Thus in LibreOffice Writer, copying and pasting emboldened text results in normal text, i.e., the formatting isn't copied into the clipboard. Only the text.

1 Answer 1

1

So...

The problem has gone away, but I don't know why!

Here's what I did:

1 - Install Gnome desktop (I already had KDE) thus:

$ sudo tasksel install ubuntu-desktop

2 - Logout, and login with Gnome

3 - Check copy and paste -- it worked fine, all formats preserved

4 - Reboot (there were updates which demanded I do so)

5 - Login with Plasma (KDE)

Now copy and paste in KDE also work fine, all formats preserved.

This seems - for now at least - to have fixed the clipboard issue. I hope it doesn't return. Perhaps this information will be of use to someone else, one day, too!

EDIT

The problem came back. I logged out of KDE, and logged in again. The problem had vanished. Clearly re-starting the KDE session fixed the fault, for now at least. I wonder how long it will stay fixed this time...

FURTHER EDIT

The problem came back again. But this time I noted it appeared after starting KRDC remote desktop connection client. So I did some testing. Now, many tests later, and a whole day, the problem seems to have stayed away. My solution was to uninstall KRDC remote desktop connection client, and use Remmina remote desktop client.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .