2

With a MATE Panel item set to 'application in terminal'

add launcher

I see xterm:

htop in xterm

I want to change that to gnome-terminal (or mate-terminal in MATE)

2

It seems to be hardcoded somewhere to use GNOME Terminal.
The logic behind this seems to be the following: if GNOME Terminal is not found, then desktop-shortcut uses xterm as fallback.

We can simulate GNOME Terminal installation on MATE by using a hack - create symlink to MATE Terminal executable:

sudo ln -s /usr/bin/mate-terminal /usr/local/bin/gnome-terminal

and then run application with MATE Terminal attached.


Note: I have faced the same problem with one of my laptops, so I asked a question on Ubuntu MATE Community. It is great that upcoming Ubuntu MATE 19.10 is not affected by this problem.

2
  • Ah good one! For my issue I needed ln -sf /usr/bin/mate-terminal /usr/bin/xterm And yes, I see other good changes coming in 19.10. – Stephen Boston Aug 31 '19 at 14:37
  • 1
    It is OK if you do not have xterm package installed. Otherwise it is not recommended as /usr/bin/xterm will be overwritten on next upgrade of xterm package. You can try to remove xterm package with sudo apt-get remove xterm and then make symlink in /usr/local/bin (this folder is not maintained by APT). – N0rbert Aug 31 '19 at 14:40
2

Or, you can change the drop-down from "Application in Terminal" to just "Application" - and before htop provide the full path to the wanted XXXX-terminal as this:
"Name: /usr/bin/gnome-terminal -e htop" (consult with man-page or help of the needed terminal application about the correct option format).

Even, maybe, with no change in the "Type" field ...

1
  • 1
    OK. My bad. I am using XFCE DE on Ubuntu 14.04. There's a default "Terminal" in "/usr/bin/xfce4-terminal" with this options : -x, --execute => Execute the remainder of the command line inside the terminal ; -e, --command=*htop* => Execute htop inside the Terminal ; -T, --title="Htop in GNME/MATE Terminal" => For setting the initial window title for the Terminal . – Jovan Ružić Aug 31 '19 at 18:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.