I cannot change the default terminal from QTerminal to Konsole.

First I use sudo update-alternatives --config x-terminal-emulator, but nothing changed (I use Ctrl+Alt+T).

Following the steps in this link:

How to change Lubuntu's default terminal?

I have to add a new shortcut. However, in this step:

Set keyboard shortcut

it doesn't recognize the keyboard shortcut as I type, or even fire the default QTerminal. How do I change that keyboard shortcut? Thanks!



From menu select Preferences -> Alternatives.Configurator, then X-terminal-emulator allows you to select from the list of installed terminals.

enter image description here

I haven't tested it (and aren't running 19.04), so don't know if the effect is immediate, or you need to logout/login for it to work.

Though if it's only CTRL+ALT+T you want to change, I'd suggest :-

From Menu select Preferences -> LXQt settings -> Shortcut Keys


  • I can't even set the keyboard shortcut. For example, when setting the shortcut, the dialog I posted above popped up, right? Then I click on the Shortcut button to start capturing the key, however Ctrl + Alt + T aren't recognised! Ctrl + Alt + ABC... works, but not T – Minh Nghĩa Aug 30 at 6:01
  • I suspect this issue relates to "We made the SUPER key the default shortcut for opening the menu. This is a no brainer. Unfortunately, I discovered this makes the Openbox SUPER key combos not work. LXQt does not consider Openbox the canonical window manager of the desktop environment, so they won't do anything to fix this." is your issue, I don't have time to explore this further for you currently, but it maybe helpful (phab.lubuntu.me/T59) Sorry currently I don't have time to chase this down right now (or refresh myself on that task), but I suspect it contains your answer – guiverc Aug 30 at 6:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.