3

I've bought a new laptop on which I have to run kernel 5.1+ because my WiFi-chip (Intel® Wi-Fi 6 AX200) wouldn't be supported otherwise. Now, I'm running into problems with VirtualBox.

The Problem

Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver is either not loaded or not
set up correctly. Please try setting it up again by executing

'/sbin/vboxconfig'

as root.

If your system has EFI Secure Boot enabled you may also need
to sign the kernel modules (vboxdrv, vboxnetflt, vboxnetadp,
vboxpci) before you can load them. Please see your Linux 
system's documentation for more information.

where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908)
The support driver is not installed. On linux, open returned ENOENT. 

What I tried

  1. sudo /sbin/vboxconfig
Please install the Linux kernel "header" files matching the current kernel
for adding new hardware support to the system.
The distribution packages containing the headers are probably:
    linux-headers-generic linux-headers-5.2.5-050205-generic

I have linux-headers-generic installed, and i can not install linux-headers-5.2.5-050205-generic because it doesn't exist. linux-headers-5.2.5-050205 exists and I have installed it, but it doesn't make a difference.

  1. If your system is using EFI Secure Boot... I have Secure Boot disabled.

  2. sudo modprobe vboxdrv

modprobe: FATAL: Module vboxdrv not found in directory /lib/modules/5.2.5-050205-generic The directory exists, but the module is indeed not there. I tried running sudo apt install --reinstall linux-headers-$(uname -r) virtualbox-dkms dkms and reboot but that did not fix the problem

  1. sudo apt remove virtualbox* and sudo apt-get install build-essential linux-headers-'uname -r' dkms virtualbox-dkms

This again gives me the error Package linux-headers-5.2.5-050205-generic is not available, but is referred to by another package., as with point 1.

  1. sudo apt-get install dkms and sudo /etc/init.d/vboxdrv setup

sudo: /etc/init.d/vboxdrv: command not found

  1. Both VirtualBox 6 and VirtualBox 5.2 have this problem.

Possible duplicates

This possible duplicate leads me to this and this post. I've tried all the solutions there but none work. My largest problem seems to be that linux-headers-5.2.5-050205-generic is missing.

Edit : this post was marked as possible duplicate, which it is not, as I have explained above.

11
1

Posting my own answer, thanks to Pilot6. I followed this guide to install kernel version 5.2.5. Using this guide, I did not install the generic version of the headers, which are needed by VirtualBox (see point 1), but the "normal" headers. Manually installing the generic headers from here fixed my issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.