0

I have an Ubuntu Server 16.04 installation that I later added Lubuntu desktop to. I then installed the x2go server (and the client on my Lubuntu 18.04 laptop).

For some years everything worked like a charm, connecting to the users active display session (to get that to work I had to change the session type to: "customized desktop" with the additional command:

lxsession -s Lubuntu -e LXDE

Sometime around February 2019, several new updates were installed and the server was restarted. After this, the client always gets a new fresh desktop session, rather than connecting to the users already running session. At the site you can still see the open windows for the local user.

I have tried use session type "connect to local desktop" but that only results in a "black screen".

How to fix this?

Additional info:

Connecting to server with ssh when no x2go client connected, and running the command x2golistdesktops returns:

username@:0

After connecting with the client (and getting a new session), running the same command results in:

username@:0
username@:50

This just confirms that the server spawns the desktop session, however the client states that it connects to :0.


Loop: WARNING! Overriding auxiliary X11 port with new value '1'.
Warning: Overriding auxiliary X11 port with new value '1'.
Info: Using abstract X11 socket in kernel namespace for accessing DISPLAY=:0.

Any ideas ?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.