0

I've been trying to roll back to cuda 10.0 with no success. I previously had Cuda 10.1 on my system, which had been installed using a runfile. I uninstalled it using the uninstall script. However, now whenever I try to install a different version of CUDA, I get Failed to initialize NVML: Driver/library version mismatch.

I have tried completely removing all versions of cuda and nvidia drivers using

sudo apt --purge remove nvidia-* sudo apt --purge remove cuda*

Then I reinstalled just the driver to see if I could get nvidia-smi to work. However, if I install 410 or 418, I get the same error message. nvidia-smi only works if I install 430.

All I can think is that there are some files that were put in place by the runfile that never got removed and that's corrupting my installation. I have been using .deb files to install cuda 10.0 and the ubuntu repository for the drivers.

I'm running ubuntu 18.04 and I have two rtx 2080ti. I have been rebooting after installing drivers, removing drivers, and installing CUDA.

  • Yes I did reboot. – Luke Aug 27 at 18:40
0

I ended up installing the 430 driver and then install cuda 10.0 using a runfile (and putting no when asked if I want to install drivers). It's running now.

0

Try purging libnvidia-compute-390 (both 64bit and 32 bit). That's the packge with libcuda.so.*


You might have up to 14 packages starting with libnvidia- associated with a specific Nvidia driver. None of these would have been picked up with a purge of "nvndia-*"

  • Tried that before. Only the runfile option mentioned in my response has worked. – Luke Aug 27 at 21:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.