2

I have a netplan config as follows on fresh install of 18.04:

network:
  version: 2
  renderer: networkd
  ethernets:
    ens224:
      addresses: [192.168.10.10/24]
      nameservers:
        addresses: [192.168.10.1]
      routes:
        - to: 192.168.10.0/24
          via: 192.168.10.1
        - to: 0.0.0.0/0
          via: 192.168.10.1
    ens192:
      addresses: [192.168.30.10/24]
      nameservers:
        addresses: [192.168.30.1]
      routes:
        - to: 192.168.30.0/24
          via: 192.168.30.1

I have 2 distinct networks (192.168.10.0/24 (Management) & 192.168.30.0/24 (User)) and they are connected via a router.

With the above Netplan, the server only responds to pings from the local subnet. e.g. from my pc on the user network, I can ping 192.168.30.10 OK but not 192.168.10.10, I get Request timed out. On the server I can see the following TCPDUMP output.

18:30:37.929682 ARP, Request who-has _gateway (Broadcast) tell 192.168.10.200, length 46 18:30:37.930562 ARP, Request who-has _gateway (Broadcast) tell 192.168.10.200, length 46 18:30:41.982129 IP xxxxx.example.com > ubuntu: ICMP echo request, id 1, seq 405, length 40 18:30:46.598802 IP xxxxx.example.com > ubuntu: ICMP echo request, id 1, seq 406, length 40 18:30:51.601718 IP xxxxx.example.com > ubuntu: ICMP echo request, id 1, seq 407, length 40 18:30:56.598075 IP xxxxx.example.com > ubuntu: ICMP echo request, id 1, seq 408, length 40 18:31:05.525346 ARP, Request who-has _gateway (Broadcast) tell 192.168.10.204, length 46 18:31:05.525556 ARP, Request who-has _gateway (Broadcast) tell 192.168.10.204, length 46

What do I need to change in my netplan to enable it to respond to requests from any subnet on any NIC? eg.

  • SSH from User network or management network to management IP
  • Ping from any network to any NIC
  • The easy fix is to enable reverse path filtering in loose mode with sysctl net.ipv4.conf.all.rp_filter = 2. However, that's frowned upon by some folks. I have a similar question at askubuntu.com/questions/1169002/… – Stefan Lasiewski Aug 30 at 20:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.