3

I have an Asus F555L model with dual boot (Ubuntu 18.04 LTS and Windows 10).

On starting my computer, I always get the option to choose between OS from the GRUB loader. However, my battery was swelling, and hence I removed it and replaced it with a new one.

Since I have done this, my computer directly goes into Windows. I do not get the option of choosing from the GRUB loader at all.

Disabling Fast Boot from BIOS hasnt helped. I have also tried pressing, Shift, Space and ESC on start but none of them helped.

I also tried putting the old battery back and it doesnt show up on that either.

What other options do I have to get my Ubuntu OS back with all my files and programs?


Boot screen from BIOS: enter image description here
Output of efibootmgr -v

ubuntu@ubuntu:~$ efibootmgr -v
BootCurrent: 0002
Timeout: 1 seconds
BootOrder: 0002,0000,0001
Boot0000* Windows Boot Manager  HD(1,GPT,75833fa7-0273-4038-ac92-599cc968ad03,0x800,0x32000)/File(\EFI\UBUNTU\GRUBX64.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...I................
Boot0001* Windows Boot Manager  HD(1,GPT,75833fa7-0273-4038-ac92-599cc968ad03,0x800,0x32000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)..BO
Boot0002* UEFI: SanDisk Cruzer Blade 1.27   PciRoot(0x0)/Pci(0x14,0x0)/USB(1,0)/HD(1,MBR,0x17b611,0x800,0x1dd1000)..BO
  • I guess your BIOS was resetted to it's default configuration. What options do you have in the Boot menu? – schrodigerscatcuriosity Aug 26 '19 at 18:16
  • Boot Option 1 (Windows), Boot Option 2 (Windows). – trollster Aug 26 '19 at 18:24
  • When restarting your PC, go to the BIOS menu and check the Boot order. If you still have Ubuntu, make it the first. Once it boots to Ubuntu, you can reinstall grub by running sudo apt install --reinstall grub-efi-amd64 for example – singrium Aug 26 '19 at 18:26
  • I do not see Ubuntu at all, unfortunately. – trollster Aug 26 '19 at 18:30
  • Do you have a switch Legacy to UEFI? – schrodigerscatcuriosity Aug 26 '19 at 18:32
4

The output of efibootmgr -v revealed that the boot-entry for Ubuntu is broken, so I recommended to make use of boot-repair which fixed the issue.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.