I'm extremely new to ubuntu. I can't seem to get rid of this error. My terminal doesn't work now. but my xterm does.

any help would be appreciated.

  • 1
    "error code(1)" simply means that some problem occurred that wasn't dpkg's fault. Please edit your question to show us the complete output of the entire apt or dpkg session, including the command(s) you were trying to run. – user535733 Aug 26 at 17:55
  • I tried to install cython. When doing so I sent command sudo apt install python3-pip. I'm struggling to even copy/paste text out of the xTerm into this comment box. Prior to throwing the sub-process /usr/bin/dpkg returned error code (1) it states "python3-apt command not found"... Still no ability to open the 'normal' terminal. Was not successful in installation of the cython – cgesling Aug 26 at 22:10
  • Thank you! output given to command "sudo apt install -f" "Reading package lists...Done Building dependency tree Reading state information ... Done 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded 1 not fully installed or removed Need to get 0B/138kB of archives. After this operation, 0 B of additional disk spalce will be used. dpkg: error processing package python3-apt (--configure): package is in a very bad inconsistent state; you should reinstall it before attempting configuration Errors were encountered while processing: – cgesling Aug 26 at 22:28
  • Try sudo apt install --reinstall python3-apt to cure the proximate error. If it reinstalls without error, then move on to sudo apt install --fix-missing – user535733 Aug 27 at 0:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.