0

I'm using Kubuntu 18.04 and I have an Nvidia graphics card with driver 430 installed. I would like to use the Nvidia GPU for its Cuda only and not for the video output. After some search online, it appears that one way to do this is to use Nvidia PRIME.

Here are my issues switching from Nvidia display output to intel (my onboard graphics card):

  1. I've seen articles and images of Nvidia X Server Settings with PRIME Profiles tab. I don't have that tab.
  2. Some people pointed out that the same functionality could be achieved with commands like sudo prime-select intel. I've done that without any errors. And when I run prime-select query, it shows me intel afterward. But still, I could only get video output out of Nvidia HDMI (after reboot). And it was a very low-resolution output without the Nvidia driver loaded.

BTW, I've purged all the Nvidia packages and reinstalled them from scratch.

Can someone please help me switch the video output to my onboard graphics card?

  • Switch it in BIOS. – Pilot6 Aug 26 '19 at 12:08
  • @Pilot6 Thanks but could you please be more specific? In this solution, do I still need the prime-select? Or just the BIOS? – Mehran Aug 26 '19 at 12:11
  • 1
    Prime-select is for laptops with hybrid graphics. It makes no sense to use it on a desktop. – Pilot6 Aug 26 '19 at 12:13
0

reference: https://devtalk.nvidia.com/default/topic/1043405/linux/ubuntu-18-04-headless_390-intel-igpu-after-prime-select-intel-lost-contact-to-geforce-1050ti/

  1. You must prime-select nvidia to enable GPU. prime-select intel will disable GPU.
  2. Create a file /etc/X11/xorg.conf:
Section "Device"
    Identifier     "intel"
    Driver         "modesetting"
    BusID          "PCI:0:2:0"
EndSection
  1. Modify /etc/default/grub, add nogpumanager in GRUB_CMDLINE_LINUX_DEFAULT parameter. Then execute update-grub.
  2. Reboot

After rebooting, in nvidia-smi you will see only 7MiB memory are used. Worked in Ubuntu 18.04 with GTX1060.

|improve this answer|||||
  • Thanks. I did almost the same with one small difference. I switched to iGPU in the BIOS. I also didn't do your step 3 and I'm not sure what does it do. But I'm getting a 2MB in my nvidia-smi and the monitor is now connected to the onboard graphic card. – Mehran Aug 31 '19 at 22:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.