How to install ktechlab in Ubuntu 11.10? enter image description here

  • There used to be a package in Ubuntu repositories, but it's not available for Oneiric. I wonder why was it removed. – Rafał Cieślak Mar 28 '12 at 21:22
  • 3
    It was removed because it relies on old KDE 3.x libraries. see - according to that bug you can install the deb package from maverick. – Alistair Buxton Mar 29 '12 at 0:11
  • How about some alternative to it? – Ashu May 25 '12 at 8:23
  • I trid many alternatives , but Did'nt got a perfect replacement – Tachyons May 25 '12 at 8:26
  • See if this or this could help – Ashu May 27 '12 at 9:25
up vote 8 down vote accepted

Compiling and Installing the latest ktechlab on Ubuntu 11.10+

This will get the latest, KDE4-port-in-progress ktechlab installed on Ubuntu 11.10 (and probably 12.04). Getting it to work may be a different story since I'm not familiar with the software. This assumes you are at the top-level of your home directory:

sudo apt-get install git kdelibs5-dev kdevplatform-dev qt4-dev-tools cmake libglib2.0-dev
mkdir git-ktechlab && cd git-ktechlab
git clone git://
cd ktechlab
mkdir build && cd build
cmake .. -DCMAKE_BUILD_TYPE=debugfull -DCMAKE_INSTALL_PREFIX=/usr/local/
sudo make install
kbuildsycoca4 &> /dev/null
update-mime-database /usr/share/mime

And then run with ktechlab. Note that it segfaults for me when clicking "New" but appears to open existing projects successfully.

Alternately, short of setting up a virtual machine running Lucid, the other option may be to create a Lucid chroot, bind your home directory to it and set the X display appropriately so that ktechlab 0.3.x is running "natively" on your 11.10 display.

Somewhat off-topic: I've never used ktechlab, but have quite a bit of experience with embedded programming, in particular PICs; but most of it was using MPLAB (and a little gpsim) along with the ICD2 (in-circuit debugger) instead of a simulator. Perhaps an ICD might work for your purposes?

Ubuntu 64bits 12.04 With this script you can solved it:

Since the work of porting ktechlab has been, unfortunately, done in the spare time of the developers, it may be a very long time before we can use it in the latest versions of Ubuntu (Kubuntu, Xubuntu, etc).

However I came across this very interesting "how-to".

It made sense and I am in the process of following the instructions to install lucid in a chroot jail to run ktechlab. It explains how you can configure it to set an icon on your desktop and a simple click from 12.04.

The site is in Portuguese, however if you use chromium-browser (and maybe others) you can translate it. Be careful with cut and pasting commands as the English translation of the commands added spaces. Just copy and paste in terminal the original text. do each step in order.

Here is the site: Click this link: How-to install ktechlab using chroot for Ubuntu 12.04

There is also a YouTube video here.

  • 1
    Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Aditya Oct 4 '13 at 8:45

For those who like and need elaborations of electronic circuits with simulation of operation to facilitate the development we have again the ktechlab that was stopped for some time in its development, and only now it was released in .tar.xz which is the compressed source code which can be extracted for eventual compilation.

enter image description here

After a setback to put it to work, I ended up compiling, installing and creating a package in .deb format where in my tests it worked perfectly on the Ubuntu 17.04 base of KDu4 and the base Kubuntu 18.04 of KDu5 Alpha4. I believe it will work normally in other Debian-based distros.

Your Answer


By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.