2

I am new to Ubuntu 18.04 and I was trying to customize it to get a proper look. I have been able to install a couple of extensions as at now. However, extensions no longer get installed. I tried using the firefox extension plugin, It starts and I get the prompt but it does not install. Like for the below extension, when I turn the switch on it starts then nothing happens. with installation from firefox .

I have also tried installing from Ubuntu Software and the extension starts installing then just stops without completing the installation. what happens when I try installing extension from Ubuntu software

AS you can see from the gifs, I have some extensions already enabled so I was thinking I had reached a limit. Does anyone have an idea of whats going on? My gnome shell version is 3.28.4.

2

You take a performance hit during startup if you have numerous gnome-extensions and depending on what the extensions do, may pay performance penalty during run time but beyond Ram and swap space limiting the amount of gnome-extensions that can run concurrently, you should be able to run many gnome-extensions.

For reference, I have a 8GB RAM machine and with around 15 or so extensions enabled and have no issues arising from this number of extensions except some hiccups during startup.

I believe there is another issue to why you are having issues. You can first check if there is something wrong with your system by manually installing extensions.

To do this, git clone or download one of these extensions to ${HOME}/.local/share/gnome-shell/extensions, making the path if it doesn't exist, and opening up dconf-editor and navigating to /org/gnome/shell/extensions/ to turn off disable-user-extensions key and adding the name of the extension to the list of enabled extensions in enabled-extensions key. The format of the name should match the directory name of the extension but most importantly the uuid key in metadata.json of the extension. You can also use gnome-shell-extension-tool with extension uuid and gnome-shell-extension-prefs to manage them. Atleast look at disable-user-extensions key if you are doing this trough gnome-shell-extension-tool and it is till not oworking.

If the manually loaded extension doesn't work or works after restarting Gnome (alt+F2 and enter r), try reinstalling gnome-shell-extensions (sudo apt install --reinstall gnome-shell-extensions). If it still doesn't work reinstall gnome-shell-common (sudo apt install --reinstall gnome-shell-common). last measure would be reinstalling gnome-shell (sudo apt install --reinstall gnome-shell).

  • @JoanMorris Must the my gnome shell version be among shell-versions specified in the metadata.json for the extension to work? – zonecc Aug 25 at 7:38
  • @zonecc From my experience, there doesn't seem to be an enforced rule that doesn't allow the extension to run if the gnome shell version isn't among shell-verisons. But if this key includes your version of gnome, the less of a chance it relies on a deprecated or new API for your specific version of gnome. – Joann Morris Aug 25 at 8:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.