0

[Edit] I have documented this problem as well as the solution that worked for me. See my answer below.

This is the laptop

https://www.costco.com/HP-Pavilion-x360-14%22-Touchscreen-2-in-1-Laptop---Intel-Core-i5---1080p---Bonus-HP-Digital-Pen.product.100431724.html

System comes pre-installed with Windows 10 and sound works fine in Windows.

I installed Ubuntu 19.04 but the sound is not working

The sound card is Intel and the Chipset is Realtek ALC295

Sound works when using the headphone but no sound from the internal speakers

0

I tried different solutions with hdajackretask, changing model in alsa-base.conf but nothing worked.

I saw an article about windows changing hardware settings when rebooting but not when shutting down. So I booted into windows, shutdown windows and then booted into Ubuntu. Internal speakers started working.

Rebooted again into Ubuntu and sound is still working.

I have reported the issue as a bug on launchpad as I believe that there is still an underlying issue - https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1841330

Hope this helps somebody.

0

I have sometimes had to use sudo alsa force-reload to get sound working again on Ubuntu 16.04. Also Check the sound settings. In my computer I find that it is sometimes helpful to change the output from inline to digital and back to inline.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.