3

I use a CCS command-line compiler for PIC programming. I've been using it and upgrading it for over a decade, and I'm comfortable with it. I recently updated to Ubuntu 19.04 64 bit, and now the program fails with a Seg Fault.

All of my other 32-bit software seems to work fine, and CCS support says it should run in 64-bit, but they have provided little other support other than that. In fact, they don't even reply other than that one answer.

Is there any way that I can force the program to run using the 32-libs? I'm just assuming that might be the issue.

Any help would be greatly appreciated.

Here are the ldd results:

ldd ccsc.bin  
    linux-gate.so.1 (0xf7fcb000)  
    libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xf7f85000)  
    libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xf7f7f000)  
    libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf7d9f000)  
    /lib/ld-linux.so.2 (0xf7fcc000)

I have located all of these libraries in '/lib/i386-linux-gnu/' except 'linux-gate.so.1'. I attempted sudo apt-get -y install linux-gate
But it was not found.

  • 3
    Use ldd on the "CCS command-line compiler" to see which libraries it uses. – waltinator Aug 24 at 21:44
  • Thanks Waltinator, – Glenn Aug 25 at 22:13
  • I added the ldd results to my question. – Glenn Aug 25 at 22:20
5

It seems that you are missing the x86 compatibility layer. To install it, you need to install some dependencies (IIRC the following):

sudo dpkg --add-architecture i386
sudo apt-get -y install lib32z1 libc6-i386 lib32stdc++6 lib32gcc1 lib32ncurses5

There may be other libs you'd need to install, but these are probably the most popular.

  • I know I ran the dpkg --add architecture. And I thought I add the needed libs, but it appears 'lib32ncurses5' could not be found. – Glenn Aug 25 at 22:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.