im been trying to stop this x-server here on ubuntu 10.04. i have done:

sudo /etc/init.d/gdm stop (doesnt do anything really)

sudo service gdm stop (stop: unknown instance)

sudo stop gdm (stop: unknown instance)

this is driving me crazy... i cant seem to find anything else to stop it, and i cant find if its a bug or not.

sudo /etc/init.d/gdm stop (only stats that i should do "sudo service gdm stop:)

this is all from the CTRL + ALT + F1 virtual interface some call it. (a command line)

i have been on this for days (3), i really need advise please!!

  • What do you have as output of pgrep -fl X?
    – enzotib
    Mar 28, 2012 at 18:53
  • 1
    1126 /usr/bin/X :0 -nr -verbose -auth /var/run/gdm/auth-for-gdm-dLyIhI/database -nolisten tcp vt7
    – Alex
    Mar 28, 2012 at 19:01
  • oh my gosh it worked, sudo /etc/init.d/gdm stop i opened terminal then this command the black screen then CTRL + ALT + F1. i have to have the gui up to run it
    – Alex
    Mar 28, 2012 at 19:28
  • thought we covered this
    – Ringtail
    Mar 28, 2012 at 19:39
  • you never told me that i run the command before pressing CTRL + ALT +F1. so i have been doing it like the tutorial says to do it. they had same command as you.
    – Alex
    Mar 28, 2012 at 19:42

1 Answer 1


OK i experienced that you run the command below before you go into CTRL + ALT + F1. if you run if afterwards. it will just advise you to run a different command.

sudo /etc/init.d/gdm stop

I was running this command to install Nvidia drivers manually.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .