2

Overall, I want to make a live usb drive that installs Windows 10. Originally I did that with unetbootin which seemed to work fine. Then I tried booting from that USB-stick but nothing showed up in the boot menu. So I checked again with gparted and it says that the entire stick has no partitions:

Unallocated partition

I get this when trying to add a new partition:

No partition table found

And this when trying to create a new partition table:

Error 1

When pressing "Retry" I get this:

Error 2

I've found a solution online where I delete the first megabyte with mkusb of the stick but that didn't change anything.

Did I brick my USB-stick or can I still save it?

  • you should unmout the usb before making filesystem changes. sudo umount /dev/sdc – Yvain Aug 24 at 15:31
  • Hi, I just tried that but nothing changed. – EVARATE Aug 24 at 15:42
  • 1
    The stick appears to be broken, replace it. – mook765 Aug 24 at 16:59
  • It's not broken if your pc can detect it. If it's mounted read only it's because it already has been set so. if you need to boot from that key the simplest thing is extract the iso image of the system on it with sudo dd if=/path/to/the image of=/path/to/the/device. it can take more than 20 minutes. – Yvain Aug 24 at 18:47
3

TL;DR ~ Just use Ubuntu's startup disk creator and write the Windows ISO directly to the USB, also do sudo dmesg and if your USB shows up then it isn't broken, in which case the table is just not created.

This is a rabbit hole that can spiral down into several other rabbit holes and you'll be dealing with more than just your immediate problem. So I'll attempt to help you as much as I can because I've walked down that road before.

First, I'll explain something quickly.

  1. Disks can have different partition tables, sometimes MSDOS, sometimes GPT, on which you can create additional partitions. There's a difference between the overall table and how its formatted. For example, you can have an MSDOS table, which you then partition into several partitions on that table. The table pretty much dictates how to find information on that drive. In the case of bootable USBs, many times they just use an ISO writable USB and wipe the table you initially had, which makes it seem broken if you're not aware of it.

  2. In your attempts to do this, you probably wiped the table and now you're trying to create a new table, probably while struggling with other issues, like it being mounted. So always remember that you can't work with drives while they're mounted.

So to add more information.

  1. Type sudo dmesg. If the USB shows up, then your USB isn't broken. If not, it's broken. dmesg is a low level Linux command that'll show all of your hardware activity.

  2. Make sure it's unmounted. You can either do this from command line using sudo umount or you can also do that from gparted.

  3. If you don't know, there is a difference between partitions and the table itself. Historically, most devices were MSDOS-formatted, but the new standard is GPT. Whatever the case, you have to create the table itself before you can create partitions on it. You can also do this from gparted by clicking on the device and creating a new table. After that you'll be able to create the partitions. Once again, make sure you've unmounted it.

  4. If what you're doing isn't working from gparted, then do it from the command line. Use dmesg or fdisk -l to find the USB name, then use umount to unmount it, then use mkfs -t ntfs /dev/* to format and create the partition itself. But don't just copy what I wrote here, research more on that command and make sure to format it correctly.

Another very important thing to consider is this: UEFI is a new standard for consistency among disks and most new disks come out with GPT tables by default. So even if you did everything correctly and it "works", if your BIOS is set to secure boot it will only recognize GPT formatted USBs and it won't recognize it if it's MSDOS. So also just make sure about that. Either disable secure boot and boot it in MSDOS, or enable secure boot and make sure it's formatted in GPT.

I'd like to add additional information based on what you're trying to do, because I've been down this rabbit hole of bootable USBs and it can get complex with trying to work with Windows. You mentioned using unetbootin, so I can only assume you're trying to create a multi boot USB, otherwise just use the Ubuntu startup disk creator and write the ISO directly to your USB.

  1. If you just want to create a single bootable USB, then just follow the instructions on the Microsoft site, they are pretty straight forward. But seeing that you're using unetbootin I can only assume that you're trying to create a USB with multiple operating systems. If that's not the case, then either just follow the Microsoft instructions or just download the ISO, open it and just copy its contents to the USB and it'll be bootable.

  2. After spending days on figuring out all of this myself, I tried every tool out there, but none of them really worked on creating multiboot USBs with Windows, at least not from Linux. In the end this is what I did.

  3. I created an MSDOS partition table on the USB, then I created 2 partitions on it, one for different Linux installations and one for the Windows installation.

  4. After you've done that use multibootusb, or whatever, to install any Linux distributions to the first partition. Then open the Windows ISO and copy the contents to the second partition.

  5. After that edit the grub menu entries and chainload to the second partition, find the menu entry for Windows and change it to something like this:

    menuentry Windows {
        insmod ntldr
        search -n -l Windows -s
        ntldr /bootmgr 
    }
    
  6. This way you can chainload from your first partition to your second partition with Windows on and you can create a USB booting anything. You can read up more on chainloading but the concept is that you're trying to add a menu entry to your grub menu that will boot from the second partition, the one containing Windows.

Important note: Please know that this is only for MSDOS and won't support GPT partitions, so make sure to format them in MSDOS. I couldn't find a way to chainload from MSDOS to GPT even trying to combine syslinux and grub, so make sure the partitions are in MSDOS.

Hope that helps.

  • Hi, thanks for the long answer. 'sudo dmesg' did show the drive but with countless error messages in between. Also the other commands didn't really change anything. The USB-stick is probably just busted and that's all right because I just got new ones :). I used unetbootin because for some reason the startup disc creator didn't show the windows iso after I selected it in the file browser... But that also doesn't matter now because I'm just gonna make the live USB-stick with another windows computer. – EVARATE Aug 24 at 17:42
  • Alright, I'm happy to hear you've sorted out everything. I'd just like to add and say that when using the startup disk creator, Ubuntu defaults to using the Downloads directory, so if your location of the ISO was at a different place, it wouldn't pick it up. So in the future if you'd like to use it, just move the ISO and it'll be picked up by startup disk creator. – Matriarx Aug 24 at 17:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.